Warning: The domain 'ghanaflaver.com' resolves to a different IP address than the one detected for this machine

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: https://ghanaflaver.com/

I ran this command: sudo /opt/bitnami/bncert-tool

It produced this output: Warning: The domain 'ghanaflaver.com' resolves to a different IP address than
the one detected for this machine, which is '3.8.249.237'. Please fix its DNS
entries or remove it. For more info see:
Configure a custom domain

My web server is (include version): bitnami

The operating system my web server runs on is (include version): linux/unix

My hosting provider, if applicable, is: aws lightsail

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): bitnami wordpress

Hi @nyarkowiz, and welcome to the LE community forum :slight_smile:

Two things:

  • Doesn't bitnami have a support forum?
    [if so, I would recommend you start there first]

  • ghanaflaver.com resolves to Cloudflare IPs:
    [they also have a support forum]

Name:      ghanaflaver.com
Addresses: 2606:4700:3035::6815:4de0
           2606:4700:3033::ac43:d420
           172.67.212.32
           104.21.77.224
4 Likes

Your domain name is proxied at Cloudflare so the DNS is pointing to the Cloudflare CDN

bncert is failing its pre-check because your servers public IP does not match that

And, that is true, it doesn't match.

So, you either have to disable the bncert pre-check or don't proxy your domain in Cloudflare

5 Likes

okay, let me try that

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.