Vps54128.public.cloudvps.com does not authorize


server seems reachable
other server in same domain worked before but now also gives same error
file is readable from azure and other platforms
file mappings are ok
what’s going on?

Kind regards,


My domain is: vps54128.public.cloudvps.com

I ran this command: letsencrypt.exe

It produced this output:

The global logger has been configured
Let’s Encrypt (Simple Windows ACME Client)
Renewal Period: 60
Certificate Store: WebHosting
ACME Server: https://acme-v01.api.letsencrypt.org/
Config Folder: xx
Certificate Folder: xx
Loading Signer from xx
Getting AcmeServerDirectory
Loading Registration from xx
Scanning IIS Site Bindings for Hosts
1: IIS vps54128.public.cloudvps.com (xx)

W: Generate a certificate via WebDav and install it manually.
F: Generate a certificate via FTP/ FTPS and install it manually.
M: Generate a certificate manually.
A: Get certificates for all hosts
Q: Quit
Choose from one of the menu options above: 1
Authorizing Identifier vps54128.public.cloudvps.com Using Challenge Type http-01
Writing challenge answer to xx.well-known/acme-challenge/gUncYjyl_e4C8RVdnA5tVlpVgVxbvy0dZNPikANd23U
Writing web.config to add extensionless mime type to xx.well-known\acme-challenge\web.config
Answer should now be browsable at http://vps54128.public.cloudvps.com/.well-known/acme-challenge/gUncYjyl_e4C8RVdnA5tVlpVgVxbvy0dZNPikANd23U
Submitting answer
Refreshing authorization
Refreshing authorization
Authorization Result: invalid
Authorization Failed invalid

The ACME server was probably unable to reach http://vps54128.public.cloudvps.com/.well-known/acme-challenge/gUncYjyl_e4C8RVdnA5tVlpVgVxbvy0dZNPikANd23U

Check in a browser to see if the answer file is being served correctly.
Authorize failed: This could be caused by IIS not being setup to handle extensionless static files.Here’s how to fix that:
1.In IIS manager goto Site/ Server->Handler Mappings->View Ordered List
2.Move the StaticFile mapping above the ExtensionlessUrlHandler mappings. (like this http://i.stack.imgur.com/nkvrL.png)
3.If you need to make changes to your web.config file, update the one at xx\web_config.xml

Press enter to continue.

My web server is (include version): iis 10

The operating system my web server runs on is (include version):
OS Name Microsoft Windows Server 2016 Standard
Version 10.0.14393 Build 14393

My hosting provider, if applicable, is: cloudvps.com

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


Hi @cornelissenja,

Your server advertises an IPv6 address, 2a02:348:5e:5ad5::1, yet is unreachable at that address. That is why the validation doesn’t complete. You should configure the server to be reachable on the IPv6 address or else remove the AAAA record.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.