Virtualmin Error: Failed to request certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
The Request Certificate Functionality in Virtualmin

It produced this output:

Requesting a certificate for,, from Let’s Encrypt …

… request failed : Web-based validation failed : Failed to request certificate : challenge did not pass: The key authorization file from the server did not match this challenge [Pk5iFQCR3JDh7SBpakdqLno-QGOGxUlwiz6dEdtgoL8.kvUJdJodMWfdyjFDfPPZWJL04nDoS_EwF0qsvOHOIJE] != []

DNS-based validation failed : Failed to request certificate : challenge did not pass: No TXT record found at

My web server is (include version):
Apache version 2.4.6

The operating system my web server runs on is (include version):
CentOS Linux 7.6.1810

My hosting provider, if applicable, is:
VPS: SpeedyKVM

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
Virtualmin 6.06

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

You can’t include mail. on your certificate, because it is CNAMEd to an external email service.

There would be no point anyway.

Just uncheck it and use only the base domain and www.

1 Like

I forgot to add. Pretty sure this is because my mail DNS is still on the hover defaults. If anyone can point me in the direction of info on how to properly configure my MX and CNAME field for “mail” that may fix this quickly. I haven’t ran a server with mail before, do they just point at the same IP?

Ah. Thanks I’ll try that.

That got it. Thanks!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.