Virtual hosts on apache work fine but the server hostname has a mismatch

My domain is: server.eyethrees.net … this is the “hostname” of my system i don’t host any content there, you will get a 403 error if you go there, after the browser complains about the cert mismatch, and all my other virtual hosts on the machine work fine

I ran this command: sudo certbot --apache

It produced this output: normal installation no errors

My web server is (include version): Apache/2.4.6 (CentOS)

The operating system my web server runs on is (include version): CentOS Linux 7.7.1908

My hosting provider, if applicable, is: n/a

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): webmin v1.930

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): v0.37.2

ONE OTHER NOTE: This is the third time trying on my own to do this. The first time I did this method (certbot via ssh). After I couldn’t figure out how to get it working properly i figured it might have something to do with webmin, so I used the webmin’s letsencrypt configuration to try again. Same result, so now i tried certbot again via ssh and it did a renewal since it saw the certs there already. And now I’m reaching out for help. TYIA*~Chris

Hi @ccheath

if you use webmin, you should always use that integrated solution. Otherwise, automatic renews may not work.

https://doxfer.webmin.com/Webmin/Let's_Encrypt

Checking your domain you have a redirect http -> https ( https://check-your-website.server-daten.de/?q=server.eyethrees.net ):

And your webmin port 10000 has already the correct certificate:

CN=server.eyethrees.net
	24.09.2019
	23.12.2019
expires in 90 days	alatrist.com, blog.chrisheath.us, 
chrisheath.us, dominusbrand.com, eyethrees.net, 
hotttsun.com, server.eyethrees.net - 7 entries

You have three different certificates:

Issuer not before not after Domain names LE-Duplicate next LE
Let’s Encrypt Authority X3 2019-09-24 2019-12-23 alatrist.com, blog.chrisheath.us, chrisheath.us, dominusbrand.com, eyethrees.net, hotttsun.com, server.eyethrees.net, www.alatrist.com, www.blog.chrisheath.us, www.chrisheath.us, www.dominusbrand.com, www.eyethrees.net, www.hotttsun.com - 13 entries duplicate nr. 1
Let’s Encrypt Authority X3 2019-09-23 2019-12-22 server.eyethrees.net - 1 entries duplicate nr. 1
Let’s Encrypt Authority X3 2019-09-22 2019-12-21 alatrist.com, blog.chrisheath.us, chrisheath.us, dominusbrand.com, eyethrees.net, hotttsun.com, server.eyethrees.net - 7 entries duplicate nr. 1

That with 13 certificates may be the best.

So

  • don’t create a new certificate, you may hit the limit
  • use that certificate with 13 domain names.

yeah i thought that i might have made those extra certs by doing it the way i did

so what’s the proper way of removing a cert?
sudo certbot delete only shows 1 cert (the one with 7 entries)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.