Verify error:Fetching

My domain is: otrs.czics.ru

I ran this command: sudo ./acme.sh/acme.sh --issue -d otrs.czics.ru --apache

It produced this output: otrs.czics.ru:Verify error:Fetching http://otrs.czics.ru/.well-known/acme-challenge/SvMKVj4kfY0KdfgzpOU1bytE_0JEEVzte8Gk7nKfRp0: Connection reset by peer

My web server is (include version): apache2

The operating system my web server runs on is (include version): Ubuntu

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): no

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): sudo ./acme.sh/acme.sh --version


v2.8.1

Hi @IlyaSiz

your port 80 doesn't answer ( https://check-your-website.server-daten.de/?q=otrs.czics.ru ):

Domainname Http-Status redirect Sec. G
http://otrs.czics.ru/
80.243.3.106 -3 0.180 W
ReceiveFailure - The underlying connection was closed: An unexpected error occurred on a receive. Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.
https://otrs.czics.ru/
80.243.3.106 302 https://otrs.czics.ru/otrs/customer.pl 0.824 N
Certificate error: RemoteCertificateChainErrors
https://otrs.czics.ru/otrs/customer.pl 200 1.187 N
Certificate error: RemoteCertificateChainErrors
http://otrs.czics.ru/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
80.243.3.106 -3 0.180 W
ReceiveFailure - The underlying connection was closed: An unexpected error occurred on a receive. Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.
Visible Content:

There is a ReceiveFailure.

If you want to use http-01 validation, a working http webserver is required.

What says

apachectl configtest
apachectl fullstatus
apachectl -S

Hello!

apachectl configtest
apache2: Syntax error on line 219 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/sites-enabled/otrs.conf: Permission denied
Action ‘configtest’ failed.
The Apache error log may have more information.
admin@OTRS:~$ apachectl fullstatus
Can’t create config directory (/.w3m)!Apache Server Status for localhost (via ::1)

Server Version: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g mod_perl/2.0.9 Perl/
v5.22.1
Server MPM: event
Server Built: 2018-06-07T19:43:03


Current Time: Monday, 03-Jun-2019 16:45:41 MSK
Restart Time: Monday, 03-Jun-2019 16:20:12 MSK
Parent Server Config. Generation: 7
Parent Server MPM Generation: 6
Server uptime: 25 minutes 28 seconds
Server load: 0.20 0.07 0.02
Total accesses: 33 - Total Traffic: 890 kB
CPU Usage: u1.38 s.27 cu0 cs0 - .108% CPU load
.0216 requests/sec - 596 B/second - 27.0 kB/request
1 requests currently being processed, 49 idle workers

PID Connections Threads Async connections
total accepting busy idle writing keep-alive closing
14196 0 yes 0 25 0 0 0
14197 0 yes 1 24 0 0 0
Sum 0 1 49 0 0 0

___W

Scoreboard Key:
“_” Waiting for Connection, “S” Starting up, “R” Reading Request,
“W” Sending Reply, “K” Keepalive (read), “D” DNS Lookup,
“C” Closing connection, “L” Logging, “G” Gracefully finishing,
“I” Idle cleanup of worker, “.” Open slot with no current process

Srv PID Acc M CPU SS Req Conn Child Slot Client VHost Request
0-6 14196 0/0/ _ 0.61 88 536 0.0 0.00 0.01 10.0.0.13 otrs.czics.ru:443 GET /otrs/index.pl?RequestedURL=https%3A%2F%2Fotrs.czics.ru%2Fo
1
0-6 14196 0/0/ _ 0.63 88 12 0.0 0.00 0.03 10.0.0.13 otrs.czics.ru:443 GET /otrs-web/skins/Agent/default/css-cache/CommonCSS_a2b70abfe
1
0-6 14196 0/0/ _ 0.64 88 1 0.0 0.00 0.01 10.0.0.13 otrs.czics.ru:443 GET /otrs-web/skins/Agent/default/css/thirdparty/ui-theme/jquer
1
0-6 14196 0/0/ _ 0.64 88 1 0.0 0.00 0.01 10.0.0.13 otrs.czics.ru:443 GET /otrs-web/skins/Agent/default/css-cache/ResponsiveCSS_e3865
1
0-6 14196 0/0/ _ 0.64 88 0 0.0 0.00 0.01 10.0.0.13
1
0-6 14196 0/0/ _ 0.07 88 0 0.0 0.00 0.00 85.215.2.229 otrs.czics.ru:443 HEAD /otrs-web/skins/Customer/default/css/thirdparty/fontawesom
1
0-6 14196 0/0/ _ 0.05 88 0 0.0 0.00 0.01 85.215.2.229 otrs.czics.ru:443 GET / HTTP/1.1
1
0-6 14196 0/0/ _ 0.06 88 0 0.0 0.00 0.07 85.215.2.229 otrs.czics.ru:443 GET /otrs-web/skins/Customer/default/css-cache/CommonCSS_1eb7a9
1
0-6 14196 0/0/ _ 0.06 88 0 0.0 0.00 0.00 85.215.2.229 otrs.czics.ru:443 HEAD /otrs-web/skins/Customer/default/css/thirdparty/fontawesom
1
0-6 14196 0/0/ _ 0.06 88 0 0.0 0.00 0.00 85.215.2.229 otrs.czics.ru:443 HEAD /otrs-web/skins/Customer/default/css/thirdparty/fontawesom
1
0-6 14196 0/0/ _ 0.07 88 0 0.0 0.00 0.00 85.215.2.229 otrs.czics.ru:443 HEAD /otrs-web/skins/Customer/default/css/thirdparty/fontawesom
1
1-6 14197 0/0/ W 0.54 0 0 0.0 0.00 0.02 ::1 OTRS.local:80 GET /server-status HTTP/1.0
2
1-6 14197 0/0/ _ 0.72 88 703 0.0 0.00 0.04 85.215.2.229 otrs.czics.ru:443 GET /otrs/customer.pl HTTP/1.1
2
1-6 14197 0/0/ _ 0.74 88 0 0.0 0.00 0.01 85.215.2.229 otrs.czics.ru:443 GET / HTTP/1.1
1
1-6 14197 0/0/ _ 0.74 88 0 0.0 0.00 0.01 85.215.2.229 otrs.czics.ru:443 HEAD /otrs-web/skins/Agent/default/img/icons/apple-touch-icon.p
2
1-6 14197 0/0/ _ 0.74 88 0 0.0 0.00 0.01 85.215.2.229 otrs.czics.ru:443 HEAD /otrs-web/skins/Agent/default/img/icons/product.ico HTTP/1
2
1-6 14197 0/0/ _ 0.75 88 0 0.0 0.00 0.01 85.215.2.229
2
1-6 14197 0/0/ _ 0.75 88 0 0.0 0.00 0.02 85.215.2.229
1
1-6 14197 0/0/ _ 0.76 88 238 0.0 0.00 0.53 85.215.2.229
1
1-6 14197 0/0/ _ 0.77 88 0 0.0 0.00 0.00 85.215.2.229 otrs.czics.ru:443 GET /otrs-web/js/js-cache/ModuleJS_923c3d3931c43ff738c158daefb0
1
1-6 14197 0/0/ _ 0.77 88 0 0.0 0.00 0.00 85.215.2.229 otrs.czics.ru:443 HEAD /otrs-web/skins/Customer/default/css/thirdparty/fontawesom
1
1-6 14197 0/0/ _ 0.77 88 0 0.0 0.00 0.00 85.215.2.229 otrs.czics.ru:443 HEAD /otrs-web/skins/Customer/default/css/thirdparty/fontawesom
1
1-6 14197 0/0/ _ 0.82 88 49 0.0 0.00 0.02 85.215.2.229 otrs.czics.ru:443 GET /otrs/customer.pl HTTP/1.1
1
1-6 14197 0/0/ _ 0.98 88 101 0.0 0.00 0.01 10.0.0.13 otrs.czics.ru:443 GET /otrs/index.pl?RequestedURL=https%3A%2F%2Fotrs.czics.ru%2Fo
1
1-6 14197 0/0/ _ 0.99 88 11 0.0 0.00 0.03 10.0.0.13 otrs.czics.ru:443 GET /otrs-web/skins/Agent/default/css-cache/CommonCSS_a2b70abfe
1
1-6 14197 0/0/ _ 1.00 88 1 0.0 0.00 0.01 10.0.0.13 otrs.czics.ru:443 GET /otrs-web/skins/Agent/default/css/thirdparty/ui-theme/jquer
1
1-6 14197 0/0/ _ 1.00 88 1 0.0 0.00 0.01 10.0.0.13 otrs.czics.ru:443 GET /otrs-web/skins/Agent/default/css-cache/ResponsiveCSS_e3865
1
1-6 14197 0/0/ _ 1.01 88 0 0.0 0.00 0.01 10.0.0.13
1


Srv Child Server number - generation
PID OS process ID
Acc Number of accesses this connection / this child / this slot
M Mode of operation
CPU CPU usage, number of seconds
SS Seconds since beginning of most recent request
Req Milliseconds required to process most recent request
Conn Kilobytes transferred this connection
Child Megabytes transferred this child
Slot Total megabytes transferred this slot


SSL/TLS Session Cache Status:
cache type: SHMCB, shared memory: 512000 bytes, current entries: 0
subcaches: 32, indexes per subcache: 88
index usage: 0%, cache usage: 0%
total entries stored since starting: 0
total entries replaced since starting: 0
total entries expired since starting: 0
total (pre-expiry) entries scrolled out of the cache: 0
total retrieves since starting: 0 hit, 0 miss
total removes since starting: 0 hit, 0 miss

Apache/2.4.18 (Ubuntu) Server at localhost Port 80

sudo apachectl -S
VirtualHost configuration:
*:80 OTRS.local (/etc/apache2/sites-enabled/000-default.conf:1)
*:443 is a NameVirtualHost
default server otrs.czics.ru (/etc/apache2/sites-enabled/000-default-le-ssl.conf:2)
port 443 namevhost otrs.czics.ru (/etc/apache2/sites-enabled/000-default-le-ssl.conf:2)
port 443 namevhost OTRS.local (/etc/apache2/sites-enabled/default-ssl.conf:2)
ServerRoot: “/etc/apache2”
Main DocumentRoot: “/var/www/html”
Main ErrorLog: “/var/log/apache2/error.log”
Mutex rewrite-map: using_defaults
Mutex ssl-stapling-refresh: using_defaults
Mutex ssl-stapling: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/var/lock/apache2" mechanism=fcntl
Mutex watchdog-callback: using_defaults
PidFile: “/var/run/apache2/apache2.pid”
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
Define: MODPERL2
Define: ENABLE_USR_LIB_CGI_BIN
User: name=“www-data” id=33
Group: name=“www-data” id=33

Run it with sudo.

Looks like you don't have a working port 80 vHost with ServerName otrs.czics.ru

So your server doesn't know what to send.

sudo apachectl configtest
Syntax OK

What should I do? It worked before

You have a lot of older certificates, first from 2016-12-06 06:49:00, last from 2019-03-04 08:31:06 ( https://check-your-website.server-daten.de/?q=otrs.czics.ru#ct-logs ).

Looks like you have used tls-sni-01 validation, that's not longer supported.

Add a working port 80 vHost with the correct ServerName. Check your existing port 80 vHost to see, how that works.

A post was split to a new topic: Website doesn’t work complete

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.