/usr/bin/systemctl: No such file or directory


#1

Hi,

I am running a cronjob on a Centos 6.8 with the apache plugin:

/usr/local/sbin/le-renew domain.com >> /var/log/le-renew.log

I got this result today:

/root/.local/share/letsencrypt/lib/python2.6/site-packages/cryptography/init.py:26: DeprecationWarning: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of cryptography will drop support for Python 2.6
DeprecationWarning
The apache plugin is not working; there may be problems with your existing configuration.
The error was: NoInstallationError()
/usr/local/sbin/le-renew: line 58: /usr/bin/systemctl: No such file or directory

While I am aware that 2.6 is deprecated, the last 3 lines sound a bit more worrying to me. Anything I should be doing about this?

In the end, the renewal process there did not finish, but when I ran it manually, it did, with the same error message.

thanks!


#2

Do you actually have Apache installed? If yes, are you sure that the service name is apache2 and not httpd?

Try “service --status-all” or “systemctl list-unit-files” to see the services and their status.
le-renew.sh script has the service name hardcoded as apache2 on line 58, could it be that plugin also expects the service to be found under the same name?


#3

Thanks for the reply! Actually I have httpd, not apache. sorry about that confusion, for me that was always pretty much the same thing.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.