Using the website directory /var/www/html .. .. request failed : Failed to request certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain

I ran this command:let script certificate request

It produced this output:raceback (most recent call last):
File “/usr/libexec/webmin/webmin/”, line 198, in
File “/usr/libexec/webmin/webmin/”, line 194, in main
signed_crt = get_crt(args.account_key, args.csr, args.acme_dir, log=LOGGER,, disable_check=args.disable_check, directory_url=args.directory_url,
File “/usr/libexec/webmin/webmin/”, line 143, in get_crt
raise ValueError(“Wrote file to {0}, but couldn’t download {1}: {2}”.format(wellknown_path, wellknown_url, e))
ValueError: Wrote file to /var/www/html/.well-known/acme-challenge/TUGsgZ_L4a_JlDmymec9pb9dooUpZEgAlQKIx5qLzrA, but couldn’t download Error:
Data: None
Response Code: 404

404 Not Found

Not Found

The requested URL /.well-known/acme-challenge/TUGsgZ_L4a_JlDmymec9pb9dooUpZEgAlQKIx5qLzrA was not found on this server.

My web server is (include version):apache

The operating system my web server runs on is (include version):centos 8

My hosting provider, if applicable,

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):webmin

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

1 Like

Is /var/www/html/ also the actual DocumentRoot of that website?

Ah, I also see your site is behind CloudFlare? What CloudFlare settings do you have enabled?

1 Like

i didnt upload website yet! is this the reason?
but i made virtualhost in var/www/ path and copeid some html test files but in this path there was an same error too.
my cloudflare setting is default! just using DNS!

1 Like

The path you provide acme_tiny should be exactly the same as the DocumentRoot directive used in Apache.

Could you perhaps provide some of those test files for us?

1 Like

thanks a lot man it resolved the path used in apache was different and as you said i found the problem i so appreciate thanksss!!!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.