Update client software

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: portal.dhc.nz

I ran this command:

It produced this output:

My web server is (include version): nginx/1.14.0 (Ubuntu)

The operating system my web server runs on is (include version):ubuntu 18.04.1

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.23.0

received an email that updating the software client should suffice. Can you advise please

1 Like

How did you install Certbot?

Can you run sudo apt update and sudo apt upgrade?

1 Like

been some time i’ve installed certbot tried this command

certbot renew --dry-run
Saving debug log to /var/log/letsencrypt/letsencrypt.log

Processing /etc/letsencrypt/renewal/portal.dhc.nz.conf

Cert not due for renewal, but simulating renewal for dry run
Plugins selected: Authenticator nginx, Installer nginx
Renewing an existing certificate
Attempting to renew cert (portal.dhc.nz) from /etc/letsencrypt/renewal/portal.dhc.nz.conf produced an unexpected error: urn:ietf:params:acme:error:malformed :: The request message was malformed :: Method not allowed. Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/portal.dhc.nz/fullchain.pem (failure)

** DRY RUN: simulating ‘certbot renew’ close to cert expiry
** (The test certificates below have not been saved.)

All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/portal.dhc.nz/fullchain.pem (failure)
** DRY RUN: simulating ‘certbot renew’ close to cert expiry
** (The test certificates above have not been saved.)

1 renew failure(s), 0 parse failure(s)

/etc/letsencrypt/renewal# apt upgrade certbot
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done

kindly advise what needs to be done next? thanks

@mnordhoff asked you to run apt upgrade (without specifying a package name) because Certbot is comprised of many packages. In this case, the specific package upgrade that will solve this for you is for python-acme, but in general, all of the packages Certbot depends on need to be kept up to date.

If you see no upgrades for either package, then make sure you have the Ubuntu PPA installed: https://certbot.eff.org/lets-encrypt/ubuntubionic-nginx

1 Like

we have a working system and see a whole lot of packages needed to be upgraded. Just worried this might cause an issue after the upgrade

Your certbot version seems outdated.
sudo apt update
sudo apt upgrade certbot

[you should be on version 0.31.0]

1 Like

Having out-of-date packages also causes issues.


thank you. upgrade did work
website went offline during the upgrade which made me worry but soon as the process was completed all back to nornal

certbot at its latest. cheers all


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.