Unexpected error: Some challenges have failed.. Invalid response from.. 404 Not Found

My domain is: proficient.fi (I got many other domains using lets encrypt, but those work correctly)

I ran this command: certbot-auto renew

It produced this output:

All other domains works correctly, but not this one.

Processing /etc/letsencrypt/renewal/proficient.fi.conf
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Cert is due for renewal, auto-renewing...
Plugins selected: Authenticator apache, Installer apache
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for proficient.fi
Waiting for verification...
Challenge failed for domain proficient.fi
http-01 challenge for proficient.fi
Cleaning up challenges
Attempting to renew cert (proficient.fi) from /etc/letsencrypt/renewal/proficient.fi.conf produced an unexpected error: Some challenges have failed.. Skipping.

Cert not yet due for renewal
All renewal attempts failed. The following certs could not be renewed:
  /etc/letsencrypt/live/proficient.fi/fullchain.pem (failure)

All renewal attempts failed. The following certs could not be renewed:
  /etc/letsencrypt/live/proficient.fi/fullchain.pem (failure)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
1 renew failure(s), 0 parse failure(s)

IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: proficient.fi
   Type:   unauthorized
   Detail: Invalid response from
   http://proficient.fi/.well-known/acme-challenge/MAxbjI9spw-szLGy9hji8aG6co1pqgYV2UujRtY5Y_g
   [95.216.39.61]: "<!DOCTYPE HTML PUBLIC \"-//IETF//DTD HTML
   2.0//EN\">\n<html><head>\n<title>404 Not
   Found</title>\n</head><body>\n<h1>Not Found</h1>\n<p"

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address.

My web server is (include version): Apache/2.4.29 (Ubuntu)
Server built: 2019-09-16T12:58:48

The operating system my web server runs on is (include version): Ubuntu Server LTS 18.04 (Bionic Beaver)

I can login to a root shell on my machine (yes or no, or I don’t know): yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
certbot-auto --version = certbot 0.39.0

I can get every other certificate but not this proficient.fi. This is peculiar because I’m not modified /etc/apache2/sites-available/*.conf files. I modified proficient.fi .htaccess, but when I found out that certificate do not work. I restore my htaccess modifying. Even domain hiekkalaatikko.proficient.fi works correctly I check compare differences hiekkalaatikko.proficient.conf file to proficient.conf file and there is different paths and FilesMatch has one more woff and I has this one line more

RewriteCond %{SERVER_NAME} =www.proficient.fi [OR]
RewriteCond %{SERVER_NAME} =proficient.fi

hiekkalaatikko.proficient.conf got only this

RewriteCond %{SERVER_NAME} =hiekkalaatikko.proficient.fi

One thing I have done. I have change my server name from hiiriohjaimet.fo to proficient.fi changing files. /etc/hosts, /etc/hostname, /etc/apache2/apache2.conf. Please help me to get this one work. proficient.fi is valid 18 days. Other are valid 38 to 79 days. Something is gone wrong with this proficient.fi.

I read somewhere and there can be two apaches runnig so I run service apache2 stop , killed the remaining apache2 processes with a killall -9 apache2 , and then started the web server back up with the service apache2 start. But this does not help because there was not another apache2 runnig.

Hi @timo

checking your domain there is an error - https://check-your-website.server-daten.de/?q=proficient.fi

http + non-www + /.well-known/acme-challenge answers with the correct http status 404 - Not Found. But www is redirected to https, then to

https://proficient.fi/tuotehakemisto

Looks like your vHost configuration is buggy.

What says

apachectl -S

root@proficient:/data# apachectl -S

VirtualHost configuration:
*:443                  is a NameVirtualHost
         default server eco-toimistotarvikkeet.fi (/etc/apache2/sites-enabled/eco-toimistotarvikkeet-le-ssl.conf:2)
         port 443 namevhost eco-toimistotarvikkeet.fi (/etc/apache2/sites-enabled/eco-toimistotarvikkeet-le-ssl.conf:2)
                 alias www.eco-toimistotarvikkeet.fi
         port 443 namevhost ergonea.fi (/etc/apache2/sites-enabled/ergonea-le-ssl.conf:2)
                 alias www.ergonea.fi
         port 443 namevhost hiekkalaatikko.eco-toimistotarvikkeet.fi (/etc/apache2/sites-enabled/hiekkalaatikko.eco-toimistotarvikkeet-le-ssl.conf:2)
         port 443 namevhost hiekkalaatikko.ergonea.fi (/etc/apache2/sites-enabled/hiekkalaatikko.ergonea-le-ssl.conf:2)
                 alias demo.ergonea.fi
         port 443 namevhost hiekkalaatikko.kassakaappi.net (/etc/apache2/sites-enabled/hiekkalaatikko.kassakaappi-le-ssl.conf:2)
         port 443 namevhost hiekkalaatikko.proficient.fi (/etc/apache2/sites-enabled/hiekkalaatikko.proficient-le-ssl.conf:2)
         port 443 namevhost hiekkalaatikko.xn--tytuoli-b1a.fi (/etc/apache2/sites-enabled/hiekkalaatikko.tyotuolikeskus-le-ssl.conf:2)
                 alias hiekkalaatikko.xn--tytuolikeskus-jmb.fi
         port 443 namevhost kassakaappi.net (/etc/apache2/sites-enabled/kassakaappi-le-ssl.conf:2)
                 alias www.kassakaappi.net
         port 443 namevhost proficient.fi (/etc/apache2/sites-enabled/proficient-le-ssl.conf:2)
                 alias www.proficient.fi
         port 443 namevhost static.eco-toimistotarvikkeet.fi (/etc/apache2/sites-enabled/static.eco-toimistotarvikkeet-le-ssl.conf:2)
         port 443 namevhost static.ergonea.fi (/etc/apache2/sites-enabled/static.ergonea-le-ssl.conf:2)
         port 443 namevhost static.kassakaappi.net (/etc/apache2/sites-enabled/static.kassakaappi-le-ssl.conf:2)
         port 443 namevhost static.proficient.fi (/etc/apache2/sites-enabled/static.proficient-le-ssl.conf:2)
         port 443 namevhost static.xn--tytuoli-b1a.fi (/etc/apache2/sites-enabled/static.tyotuolikeskus-le-ssl.conf:2)
                 alias static.xn--tytuolikeskus-jmb.fi
         port 443 namevhost template.eco-toimistotarvikkeet.fi (/etc/apache2/sites-enabled/template.eco-toimistotarvikkeet-le-ssl.conf:2)
         port 443 namevhost template.ergonea.fi (/etc/apache2/sites-enabled/template.ergonea-le-ssl.conf:2)
         port 443 namevhost template.kassakaappi.net (/etc/apache2/sites-enabled/template.kassakaappi-le-ssl.conf:2)
         port 443 namevhost template.proficient.fi (/etc/apache2/sites-enabled/template.proficient-le-ssl.conf:2)
         port 443 namevhost template.xn--tytuoli-b1a.fi (/etc/apache2/sites-enabled/template.tyotuolikeskus-le-ssl.conf:2)
                 alias template.xn--tytuolikeskus-jmb.fi
         port 443 namevhost xn--tytuoli-b1a.fi (/etc/apache2/sites-enabled/tyotuolikeskus-le-ssl.conf:2)
                 alias www.xn--tytuoli-b1a.fi
                 alias xn--tytuolikeskus-jmb.fi
                 alias www.xn--tytuolikeskus-jmb.fi
*:80                   is a NameVirtualHost
         default server proficient.fi (/etc/apache2/sites-enabled/000-default.conf:1)
         port 80 namevhost proficient.fi (/etc/apache2/sites-enabled/000-default.conf:1)
         port 80 namevhost eco-toimistotarvikkeet.fi (/etc/apache2/sites-enabled/eco-toimistotarvikkeet.conf:1)
                 alias www.eco-toimistotarvikkeet.fi
         port 80 namevhost ergonea.fi (/etc/apache2/sites-enabled/ergonea.conf:1)
                 alias www.ergonea.fi
         port 80 namevhost hiekkalaatikko.eco-toimistotarvikkeet.fi (/etc/apache2/sites-enabled/hiekkalaatikko.eco-toimistotarvikkeet.conf:1)
         port 80 namevhost hiekkalaatikko.ergonea.fi (/etc/apache2/sites-enabled/hiekkalaatikko.ergonea.conf:1)
                 alias demo.ergonea.fi
         port 80 namevhost hiekkalaatikko.kassakaappi.net (/etc/apache2/sites-enabled/hiekkalaatikko.kassakaappi.conf:1)
         port 80 namevhost hiekkalaatikko.xn--kynjakumi-x2a.fi (/etc/apache2/sites-enabled/hiekkalaatikko.kynajakumi.conf:1)
         port 80 namevhost hiekkalaatikko.proficient.fi (/etc/apache2/sites-enabled/hiekkalaatikko.proficient.conf:1)
         port 80 namevhost hiekkalaatikko.xn--tytuoli-b1a.fi (/etc/apache2/sites-enabled/hiekkalaatikko.tyotuolikeskus.conf:1)
                 alias hiekkalaatikko.xn--tytuolikeskus-jmb.fi
         port 80 namevhost kassakaappi.net (/etc/apache2/sites-enabled/kassakaappi-le-ssl.conf:27)
                 alias www.kassakaappi.net
         port 80 namevhost kassakaappi.net (/etc/apache2/sites-enabled/kassakaappi.conf:1)
                 alias www.kassakaappi.net
         port 80 namevhost xn--kynjakumi-x2a.fi (/etc/apache2/sites-enabled/kynajakumi.conf:1)
                 alias www.xn--kynjakumi-x2a.fi
         port 80 namevhost xn--flppitaulu-r5a.fi (/etc/apache2/sites-enabled/muut.conf:1)
                 alias www.xn--flppitaulu-r5a.fi
         port 80 namevhost hiiriohjaimet.fi (/etc/apache2/sites-enabled/muut.conf:19)
                 alias www.hiiriohjaimet.fi
         port 80 namevhost ilmoitustaulut.fi (/etc/apache2/sites-enabled/muut.conf:38)
                 alias www.ilmoitustaulut.fi
         port 80 namevhost satulatuolit.fi (/etc/apache2/sites-enabled/muut.conf:57)
                 alias www.satulatuolit.fi
         port 80 namevhost xn--tytuoleja-17a.fi (/etc/apache2/sites-enabled/muut.conf:76)
                 alias www.xn--tytuoleja-17a.fi
         port 80 namevhost valkokankaita.fi (/etc/apache2/sites-enabled/muut.conf:95)
                 alias www.valkokankaita.fi
         port 80 namevhost valkotauluja.fi (/etc/apache2/sites-enabled/muut.conf:114)
                 alias www.valkotauluja.fi
         port 80 namevhost proficient.fi (/etc/apache2/sites-enabled/proficient.conf:1)
                 alias www.proficient.fi
         port 80 namevhost static.eco-toimistotarvikkeet.fi (/etc/apache2/sites-enabled/static.eco-toimistotarvikkeet.conf:1)
         port 80 namevhost static.ergonea.fi (/etc/apache2/sites-enabled/static.ergonea.conf:1)
         port 80 namevhost static.kassakaappi.net (/etc/apache2/sites-enabled/static.kassakaappi-le-ssl.conf:24)
         port 80 namevhost static.kassakaappi.net (/etc/apache2/sites-enabled/static.kassakaappi.conf:1)
         port 80 namevhost static.xn--kynjakumi-x2a.fi (/etc/apache2/sites-enabled/static.kynajakumi.conf:1)
         port 80 namevhost static.proficient.fi (/etc/apache2/sites-enabled/static.proficient.conf:1)
         port 80 namevhost static.xn--tytuoli-b1a.fi (/etc/apache2/sites-enabled/static.tyotuolikeskus.conf:1)
                 alias static.xn--tytuolikeskus-jmb.fi
         port 80 namevhost template.eco-toimistotarvikkeet.fi (/etc/apache2/sites-enabled/template.eco-toimistotarvikkeet.conf:1)
         port 80 namevhost template.ergonea.fi (/etc/apache2/sites-enabled/template.ergonea.conf:1)
         port 80 namevhost template.kassakaappi.net (/etc/apache2/sites-enabled/template.kassakaappi.conf:1)
         port 80 namevhost template.xn--kynjakumi-x2a.fi (/etc/apache2/sites-enabled/template.kynajakumi.conf:1)
         port 80 namevhost template.proficient.fi (/etc/apache2/sites-enabled/template.proficient.conf:1)
         port 80 namevhost template.xn--tytuoli-b1a.fi (/etc/apache2/sites-enabled/template.tyotuolikeskus.conf:1)
                 alias template.xn--tytuolikeskus-jmb.fi
         port 80 namevhost xn--tytuoli-b1a.fi (/etc/apache2/sites-enabled/tyotuolikeskus.conf:1)
                 alias www.xn--tytuoli-b1a.fi
                 alias xn--tytuolikeskus-jmb.fi
                 alias www.xn--tytuolikeskus-jmb.fi
         port 80 namevhost vanha.kassakaappi.net (/etc/apache2/sites-enabled/vanha.kassakaappi.conf:1)
ServerRoot: "/etc/apache2"
Main DocumentRoot: "/var/www/html"
Main ErrorLog: "/var/log/apache2/error.log"
Mutex mpm-accept: using_defaults
Mutex watchdog-callback: using_defaults
Mutex rewrite-map: using_defaults
Mutex ssl-stapling-refresh: using_defaults
Mutex ssl-stapling: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/var/lock/apache2" mechanism=fcntl
PidFile: "/var/run/apache2/apache2.pid"
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name="www-data" id=33
Group: name="www-data" id=33

I have done in PHP code that if there is not found address it redirects to “https://proficient.fi/tuotehakemisto”, but I do no know why it do not work

http://proficient.fi/wwww

Goes to: Not Found The requested URL was not found on this server.

http://www.proficient.fi/wwew
Goes to:
Your connection is not encrypted
An attacker on www.proficient.com may attempt to steal your information (such as passwords, messages, or credit card information). More information
NET :: ERR_CERT_COMMON_NAME_INVALID

Is this the reason?

Beacuse:

http://eco-toimistotarvikkeet.fi/wwww

AND

http://www.eco-toimistotarvikkeet.fi/wwww

Goes to tuotehakemisto, like it should.

There is your buggy config. Two port 80 vHosts with the same set of domain names.

Every combination of port and list of domain names must be unique. If not, you have unexpected results.

Merge both in one vHost, delete the other, restart your server.

1 Like

Thank you for your time and answer. When I looked the result strictly I see the problem. This is new kind of problem to me. But how to I do it?

     default server proficient.fi (/etc/apache2/sites-enabled/000-default.conf:1)
     port 80 namevhost proficient.fi (/etc/apache2/sites-enabled/000-default.conf:1)

port 80 namevhost proficient.fi (/etc/apache2/sites-enabled/proficient.conf:1)
alias www.proficient.fi

How to I remove port 80 namevhost proficient.fi (/etc/apache2/sites-enabled/000-default.conf:1)
and default server proficient.fi (/etc/apache2/sites-enabled/000-default.conf:1)
And put it default server proficient.fi (/etc/apache2/sites-enabled/proficient.conf:1)

That's not the problem, that's only one vHost. You have two.

Yes I understand I have twice same domain or should I say vhost which have same domain, but goes to diffferent paths.

port 80 namevhost proficient.fi (/etc/apache2/sites-enabled/000-default.conf:1)
port 80 namevhost proficient.fi (/etc/apache2/sites-enabled/proficient.conf:1)

But here only one so how I can remove the other?
/etc/apache2/sites-enabled/

proficient.conf -> …/sites-available/proficient.conf
proficient-le-ssl.conf -> /etc/apache2/sites-available/proficient-le-ssl.conf

So how can I remove this
port 80 namevhost proficient.fi (/etc/apache2/sites-enabled/000-default.conf:1) ?

Where it is said that port 80 namevhost proficient.fi
goes (/etc/apache2/sites-enabled/000-default.conf:1) ?

So I can’t understand how to remove the other vhost. Is it symlink ?
My /etc/apache2/sites-enabled/

000-default.conf -> …/sites-available/000-default.conf
proficient.conf -> …/sites-available/proficient.conf
proficient-le-ssl.conf -> /etc/apache2/sites-available/proficient-le-ssl.conf

000-default.conf do not link to proficient. So where is it said that
port 80 namevhost proficient.fi (/etc/apache2/sites-enabled/000-default.conf:1)

My 000-default.conf contains following

/etc/apache2/sites-available/000-default.conf

<VirtualHost *:80>
# The ServerName directive sets the request scheme, hostname and port that
# the server uses to identify itself. This is used when creating
# redirection URLs. In the context of virtual hosts, the ServerName
# specifies what hostname must appear in the request’s Host: header to
# match this virtual host. For the default virtual host (this file) this
# value is not decisive as it is used as a last resort host regardless.
# However, you must set it for any further virtual host explicitly.
#ServerName www.example.com

    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html

    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf

vim: syntax=apache ts=4 sw=4 sts=4 sr noet

I put VirtualHost configuration in order I found out that *:80 is a NameVirtualHost
kassakaappi.net and proficient.fi has vhost with same port twice. How I manage these?

proficient.fi this has same port and vhost twice
default server proficient.fi (/etc/apache2/sites-enabled/000-default.conf:1)
port 80 namevhost proficient.fi (/etc/apache2/sites-enabled/000-default.conf:1)
port 80 namevhost proficient.fi (/etc/apache2/sites-enabled/proficient.conf:1)
alias www.proficient.fi
port 80 namevhost static.proficient.fi (/etc/apache2/sites-enabled/static.proficient.conf:1)
port 80 namevhost template.proficient.fi (/etc/apache2/sites-enabled/template.proficient.conf:1)
port 80 namevhost hiekkalaatikko.proficient.fi (/etc/apache2/sites-enabled/hiekkalaatikko.proficient.conf:1)

kassakaappi.net this has same port and vhost twice
port 80 namevhost kassakaappi.net (/etc/apache2/sites-enabled/kassakaappi-le-ssl.conf:27)
alias www.kassakaappi.net
port 80 namevhost kassakaappi.net (/etc/apache2/sites-enabled/kassakaappi.conf:1)
alias www.kassakaappi.net
port 80 namevhost static.kassakaappi.net (/etc/apache2/sites-enabled/static.kassakaappi-le-ssl.conf:24)
port 80 namevhost static.kassakaappi.net (/etc/apache2/sites-enabled/static.kassakaappi.conf:1)
port 80 namevhost template.kassakaappi.net (/etc/apache2/sites-enabled/template.kassakaappi.conf:1)
port 80 namevhost hiekkalaatikko.kassakaappi.net (/etc/apache2/sites-enabled/hiekkalaatikko.kassakaappi.conf:1)

If I manage these with /etc/apache2/sites-enabled folder how I do it because there is no such symlink?

Here is my /etc/apache2/sites-enabled

000-default.conf -> …/sites-available/000-default.conf
eco-toimistotarvikkeet.conf -> …/sites-available/eco-toimistotarvikkeet.conf
eco-toimistotarvikkeet-le-ssl.conf -> /etc/apache2/sites-available/eco-toimistotarvikkeet-le-ssl.conf
ergonea.conf -> …/sites-available/ergonea.conf
ergonea-le-ssl.conf -> …/sites-available/ergonea-le-ssl.conf
hiekkalaatikko.eco-toimistotarvikkeet.conf -> …/sites-available/hiekkalaatikko.eco-toimistotarvikkeet.conf
hiekkalaatikko.eco-toimistotarvikkeet-le-ssl.conf -> /etc/apache2/sites-available/hiekkalaatikko.eco-toimistotarvikkeet-le-ssl.conf
hiekkalaatikko.ergonea.conf -> …/sites-available/hiekkalaatikko.ergonea.conf
hiekkalaatikko.ergonea-le-ssl.conf -> …/sites-available/hiekkalaatikko.ergonea-le-ssl.conf
hiekkalaatikko.kassakaappi.conf -> …/sites-available/hiekkalaatikko.kassakaappi.conf
hiekkalaatikko.kassakaappi-le-ssl.conf -> /etc/apache2/sites-available/hiekkalaatikko.kassakaappi-le-ssl.conf
hiekkalaatikko.kynajakumi.conf -> …/sites-available/hiekkalaatikko.kynajakumi.conf
hiekkalaatikko.proficient.conf -> …/sites-available/hiekkalaatikko.proficient.conf
hiekkalaatikko.proficient-le-ssl.conf -> /etc/apache2/sites-available/hiekkalaatikko.proficient-le-ssl.conf
hiekkalaatikko.tyotuolikeskus.conf -> …/sites-available/hiekkalaatikko.tyotuolikeskus.conf
hiekkalaatikko.tyotuolikeskus-le-ssl.conf -> /etc/apache2/sites-available/hiekkalaatikko.tyotuolikeskus-le-ssl.conf
kassakaappi.conf -> …/sites-available/kassakaappi.conf
kassakaappi-le-ssl.conf -> /etc/apache2/sites-available/kassakaappi-le-ssl.conf
kynajakumi.conf -> …/sites-available/kynajakumi.conf
muut.conf -> …/sites-available/muut.conf
proficient.conf -> …/sites-available/proficient.conf
proficient-le-ssl.conf -> /etc/apache2/sites-available/proficient-le-ssl.conf
static.eco-toimistotarvikkeet.conf -> …/sites-available/static.eco-toimistotarvikkeet.conf
static.eco-toimistotarvikkeet-le-ssl.conf -> /etc/apache2/sites-available/static.eco-toimistotarvikkeet-le-ssl.conf
static.ergonea.conf -> …/sites-available/static.ergonea.conf
static.ergonea-le-ssl.conf -> …/sites-available/static.ergonea-le-ssl.conf
static.kassakaappi.conf -> …/sites-available/static.kassakaappi.conf
static.kassakaappi-le-ssl.conf -> /etc/apache2/sites-available/static.kassakaappi-le-ssl.conf
static.kynajakumi.conf -> …/sites-available/static.kynajakumi.conf
static.proficient.conf -> …/sites-available/static.proficient.conf
static.proficient-le-ssl.conf -> /etc/apache2/sites-available/static.proficient-le-ssl.conf
static.tyotuolikeskus.conf -> …/sites-available/static.tyotuolikeskus.conf
static.tyotuolikeskus-le-ssl.conf -> /etc/apache2/sites-available/static.tyotuolikeskus-le-ssl.conf
template.eco-toimistotarvikkeet.conf -> …/sites-available/template.eco-toimistotarvikkeet.conf
template.eco-toimistotarvikkeet-le-ssl.conf -> /etc/apache2/sites-available/template.eco-toimistotarvikkeet-le-ssl.conf
template.ergonea.conf -> …/sites-available/template.ergonea.conf
template.ergonea-le-ssl.conf -> …/sites-available/template.ergonea-le-ssl.conf
template.kassakaappi.conf -> …/sites-available/template.kassakaappi.conf
template.kassakaappi-le-ssl.conf -> /etc/apache2/sites-available/template.kassakaappi-le-ssl.conf
template.kynajakumi.conf -> …/sites-available/template.kynajakumi.conf
template.proficient.conf -> …/sites-available/template.proficient.conf
template.proficient-le-ssl.conf -> /etc/apache2/sites-available/template.proficient-le-ssl.conf
template.tyotuolikeskus.conf -> …/sites-available/template.tyotuolikeskus.conf
template.tyotuolikeskus-le-ssl.conf -> /etc/apache2/sites-available/template.tyotuolikeskus-le-ssl.conf
tyotuolikeskus.conf -> …/sites-available/tyotuolikeskus.conf
tyotuolikeskus-le-ssl.conf -> …/sites-available/tyotuolikeskus-le-ssl.conf
vanha.kassakaappi.conf -> …/sites-available/vanha.kassakaappi.conf

I ask how to delete the other? Where it is. Where the file location is?
It is not in my case /etc/apache2/sites-enabled

What shoud I do? Should I use a2dissite to proficient and get new certificate to it? Or what is the solution. How I can clear or modify those vhost which apachectl -S show? That there is just one vhost to one domain and port. Please help! I think the solution is not tricky one.

Delete it, rename it, name it "localhost".

I just run:

a2dissite 000-default.conf

systemctl reload apache2

certbot-auto renew

And all works now. The thing I do no understand was that namevhost proficient.fi
is linked to the /etc/apache2/sites-enabled/000-default.conf
I think 000-default.conf is symlinked to some how proficient in folder
/etc/apache2/sites-enabled. So I read and read all over again and there is no symlink
/etc/apache2/sites-enabled/000-default.conf --> proficient files. Anyway I finally understand that the solution is right in my eyes. Thank you JuergenAuer very much for your time and answers!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.