Unable to renew


#1

The first installation works great. I can select my domains, force https and all that.

But if I try to add SSL to new domains I always get the error “unable to find a vhost”.

I have three domains currently and my FQDM is “host.example.de”.

I’ve searched for this error but nothing worked for me.

Any help would be appreciated :slight_smile:

EDIT
Full domain name: kazuto.de, dienstleistungen-klose.de, stream-studio.de
Command line: certbot --apache certonly
Output: unable to find a vhost
Debian Jessie 8.7 | Apache/2.4.10 (Debian)
Hosting provider: Netcup.de


#2

Hi @Kazu,

Could you please fill in all of the fields in the help template? When you submit a new help request on this forum, a document should appear with a number of questions related to your configuration. Having all of that information will help people here to help you.


#3

I’ve answered all questions and edited my first post ^^


#4

Hi @Kazu,

Thanks for the further information.

What did you mean by “try to add SSL to new domains” here? In what way are they “new”, and what are you doing to “try to add SSL” to them?


#5

I’m using i-MSCP as my ACP.
When I add a new domain or subdomain, I have to run certbot --apache certonly in order to renew the certificate for the freshly added domains. But if I do so it tells me that it’s unable to find a vhost and that I have to select one so I try to use host.kazuto.de because this is my host, but giving me an error afterwards.


#6

Do you have multiple VirtualHosts defined in a single configuration file within /etc/apache2? The current version of Certbot cannot handle this situation correctly, yet very often fails to warn about it.


#7

Which files do I need to check?

000-default.conf
kazuto.de.conf
stream-studio.de.conf
dienstleistungen-klose.de.conf


#8

You should check each of them.


#9

What do I need to check? Never worked with vhosts before.

There is only <VirtualHost 37.120.174.194:80> in each file, but two ServerAlias e.g. www.kazuto.de vu2003.admin.kazuto.de


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.