Unable to obtain certificate for top-level domain

Hello letsencrypt community!

I am trying to set up SSL access to my server (who’d guessed it). My setup is the following:
domain christianzollner.com is permantently redirecting with masking to christianzollner.ddns.net (no-ip service) which is then pointing to my raspberry pi server.

I was able to set up the SSL certificate for christianzollner.ddns.net but I am struggling to set it up for the christianzollner.com domain and I ran out of clues. The command shown below is the latest one I tried, so I guess it’s a starting point. To me it seems somehow that the certbot isn’t following the forwarding from the top-level domain to the no-ip service - but really, I am just guessing.

Thank you for any assistance!!

My domain is: christianzollner.com (forwarding to christianzollner.ddns.net)

I ran this command: sudo certbot certonly --apache -d christianzollner.com --dry-run

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for christianzollner.com
Enabled Apache rewrite module
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. christianzollner.com (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://christianzollner.com/.well-known/acme-challenge/H_TK2a5UYnX01KWVO3Uj3cWw-bFaQNFXZP8cJq7Clzg: Timeout during connect (likely firewall problem)


  • The following errors were reported by the server:

    Domain: christianzollner.com
    Type: connection
    Detail: Fetching
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version):
Server version: Apache/2.4.38 (Raspbian)
Server built: 2019-10-15T19:53:42

The operating system my web server runs on is (include version): Raspbian Buster

My hosting provider, if applicable, is: self-hosted on my Raspi

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): cerbot 0.31.0

1 Like

Hi @osterchrisi

your dns setup is wrong, that can't work. Checking your domain - https://check-your-website.server-daten.de/?q=christianzollner.com

Host T IP-Address is auth. ∑ Queries ∑ Timeout
christianzollner.com A Scottsdale/Arizona/United States (US) - GoDaddy.com, LLC Hostname: ip-184-168-131-241.ip.secureserver.net yes 2 0
AAAA yes
www.christianzollner.com C christianzollner.com yes 1 0
A Scottsdale/Arizona/United States (US) - GoDaddy.com, LLC Hostname: ip-184-168-131-241.ip.secureserver.net yes

that's your ip address.

And there is a wrong frame:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd"> <html> <head> <title>Christian Zollner</title> <meta name="description" content=""> <meta name="keywords" content=""> </head> 
<frameset rows="100%,*" border="0"> 
<frame src="http://christianzollner.ddns.net/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de" frameborder="0" />
 </frameset> </html> 

Your domain must have the ip address of your christianzollner.ddns.net, if you want to use http validation.

If this isn't possible, you can't use http validation -> you may use dns validation.

1 Like

Hello Jürgen!

Thanks for your help here.

Aha! So simply forwarding the traffic is not the way to go with “standard” certbot usage? Do I understand you correctly that I either

  1. Have to be able to change the DNS record of christianzollner.com to have the IP adress of christianzollner.ddns.net (I think I can’t) OR
  2. Have the (working) forwarding to christianzollner.ddns.net in place and complete a DNS challenge (from the link you provided)?

Thank you.

Second doesn’t help, because you can’t install the certificate on the GoDaddy ip

So your main domain must point to an ip address you are able to manage if you want to install a certificate.

Conclusion: Use your ddns domain.


Thanks again, Herr Auer! I changed the CNAME record from my registrar to point to christianzollner.ddns.net and (after a little while) it worked! Great! :grinning:

1 Like

That's possible. But then it's not longer possible to use the mail of GoDaddy.

That may be ok - or it may be bad.

CNAME -> "ask the other domain / hoster".

I don’t neet to use mail from GoDaddy (actually my registrar is cheap-registrar…).

I have one more question please: Now I have
https://www.christianzollner.com and

successfully running via SSL. But I don’t see how it is possible to get

working with SSL. This is because my registrar won’t accept “@” in my CNAME record (is this normal?) and I can’t provide a (corret) static IP adress for an A record. I also tried forwarding christianzollner.com to https://christianzollner.ddns.net but then again, my registar automatically creates an A record with the IP adress of my top-level domain (where I can’t install certificates).

How can I achieve SSL access to https://christianzollner.com ?

1 Like

Use another DNS registrar.

If GoDaddy blocks that

you can't use it. But it's provider-specific -> accept it or change your provider.

1 Like

Alright, thank you very much for your help. I will leave it like this for now (page isn’t even made yet) and take care of this later.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.