Unable to install SSL on nginx Vultr - Wordpress

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: lockandsecure.com

I ran this command:
./certbot-auto certonly --standalone
(followed this guide)

It produced this output:
The Certbot installer will ask whether to proceed with the download. Enter “Y” to continue. Enter your email when prompted. This will be used to send you notices regarding renewal and security. Enter “A” to agree to the terms of service. Select whether you want to share your email with the Electronic Frontier Foundation. This is optional. Enter the domain names for which you want an SSL certificate separated by a space…

example.com www.example.com

My web server is (include version):
nginx
centos6

The operating system my web server runs on is (include version):
centos6 (application) wordpress

My hosting provider, if applicable, is:
vultr
I can login to a root shell on my machine (yes or no, or I don’t know):
yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no

Hi @mrelliot008,

Can you explain more about your problem here? Did you see an error message? Was your certificate successfully issued or not?

I’ve been following this guide to install SSL on Lockandsecure.com But, the issue is that

After this step:

Certbot automates the process of obtaining certificates by providing an interactive installer.

./certbot-auto certonly --standalone

It Must show the below mentioned options

The Certbot installer will ask whether to proceed with the download. Enter “Y” to continue. Enter your email when prompted. This will be used to send you notices regarding renewal and security. Enter “A” to agree to the terms of service. Select whether you want to share your email with the Electronic Frontier Foundation. This is optional. Enter the domain names for which you want an SSL certificate separated by a space…

Instead of this I’m getting this error:

Error: Command ‘[’/opt/eff.org/certbot/venv/bin/python3’, ‘-Im’, ‘ensurepip’, ‘–upgrade’, ‘–default-pip’]’ returned non-zero exit status 1

How to fix this issue so, that I can install the ssl certificate and move forward with this.

Thanks, it’s very helpful to see the exact error message!

It looks like several people have had the same problem:

https://community.letsencrypt.org/search?q=ensurepip

One person claimed to solve it by setting the locale:

I don’t immediately understand why that would be relevant here, but maybe you could try that and report back on whether it works? If it doesn’t, we can try to get some other people involved with more knowledge of the dependencies and packaging issues.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.