Unable to connect to the server after using certbot-nginx

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
https://starfarm.com

I ran this command:

sudo certbot --nginx -d starfarm.com -d www.starfarm.com

It produced this output:
Congratulations! You have successfully enabled https://starfarm.com andhttps://www.starfarm.comYou should test your configuration at:https://www.ssllabs.com/ssltest/analyze.html?d=starfarm.comhttps://www.ssllabs.com/ssltest/analyze.html?d=www.starfarm.com- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -IMPORTANT NOTES: - Congratulations! Your certificate and chain have been saved at: /etc/letsencrypt/live/starfarm.com/fullchain.pem

My web server is (include version):
Nginx (1.10.3)

The operating system my web server runs on is (include version):
Ubuntu 16.04 (I was able to replicate the issue exactly on Ubuntu 18.04

My hosting provider, if applicable, is:
AWS Lightsail

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
No this is a plain Linux server

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31.0

Once performing the certbot command, I am getting Unable to connect to the server from SSL Labs.

I am able to replicate this issue on both Ubuntu 16.04 and Ubuntu 18.04.

You probably just need to update your Lightsail firewall to allow HTTPS - port 443 (TCP). See this page in the Lightsail docs.

By default, it seems to be excluded:

Amazon Linux, CentOS, Debian, FreeBSD, openSUSE, and Ubuntu (base operating systems)

SSH - TCP - 22

HTTP - TCP - 80

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.