Unable invoke backend after SSL certification

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:depotrace.com

I ran this command:

It produced this output:SSL_PROTOCOL_ERROR

My web server is (include version):React js

The operating system my web server runs on is (include version):Google Cloud

My hosting provider, if applicable, is:GoDaddy

I can login to a root shell on my machine (yes or no, or I don't know):Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):Yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):V1.32.0

Seems to be working just fine, what exactly is your issue?

my react application which is running on port 3000 has rerouted to port 80 using nginx,
i have done this procedure during ssl certificate for my domain,now my domain which is using https is uanble to make calls to the backend which is running on port 9000

When I surf to https://depotrace.com/ I can see a website. Is that not what should be shown?

Also, you might want to have mentioned you're using nginx as the frond end to your ReactJS thingy in the first place.

Also nr 2: "yes" was not a valid answer to the control panel question..

Also nr 3: "Google Cloud" is not an operating system.Hm, there seems to be something that is called "Google Cloud OS"..

When i am entering some credentials and try to login backend is not invoked ,that is the issue

OS:Ubuntu

I have no idea what that means and I have no idea how that would be related to Let's Encrypt?

Can you provide more details please?


Simply looking at the Chrome Developer Toolbars console, when I try to "login", I'm seeing:

POST https://34.100.154.254:9000/api/auth/login net::ERR_CONNECTION_REFUSED

Well, that's not going to work obviously if there's a front end in front of the backend. It should try to connect to your website (using the hostname, not IP address) on port 443, not to some IP address on port 9000?

Also, unrelated, you might want to add a HTTP to HTTPS redirect on port 80 (HTTP).

2 Likes

http://depotrace.com:9000/sales/sales ,so this is where my backend runs,but i am unable to call it from front end

Do you mean "from a browser"? Because if not, I'm puzzeling what you're meaning / trying to do..

Also, what's running on port 9000 and what's running on the earlier mentioned port 3000? Isn't this more of a "how to set up nginx as a reverse proxy" question? I'm still failing to see how this is Let's Encrypt related.

2 Likes

front-end on 3000 ,
back-end on 9000,
this issue arised when i deployed ssl for my domain before that it worked properly,
if this isn't letsencrypt ssl issues then thanks for your help

1 Like

There's nothing listening on port 3000 from the public internet, but there is on port 443.

Due to the lack of understanding your exact setup in details, especially the situation before and after and how you got the certificate et cetera I cannot answer this question completely.

Also, as mentioned before, your website works perfectly on https://depotrace.com/ except for the bogus login form destination. So whatever it is you're dealing with, please provide way more information than "it doesn't work". That's not something we can work with.

2 Likes

What is running on port 9000?
How do you connect to now?
How did you connect to it before you added HTTPS to the main site?

4 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.