Typo in domain name Certbot auto

I used Certbot auto, but didn’t realize that I had misspelled my domain name. The first time I ran through the process, I got an error that I needed to create a virtual host. After I did that, I tried to run it again, but it insists upon the misspelled domain name. I tried deleting the Letsencrypt folder and reinstall Certbot, but it didn’t help. Please advise.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: dgarlock.us

I ran this command: sudo /usr/local/bin/certbot-auto --apache

It produced this output:

My web server is (include version): Apache 2.3

The operating system my web server runs on is (include version): Centos 6.10

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): current

1 Like

Certbot’s Apache plugin gets the default list of names by parsing the Apache configuration. Are you sure Apache is configured with the correct spelling?


Thank you very much. The typo was in the httpd config file when I created the Vhost. I really appreciate the help.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.