Turning off debug


#1

Is it possible to turn off debug, the log entries contain a lot of stuff that is of no interest to me.


#2

Please just open one topic - as this seems a duplicate.

usually not using the -debug option turns off debug.


#3

To the best of my knowledge -debug is not turned on.
Where would I find this option being set?


#4

Usually on the command line or in the config file ( which by default is /etc/letsencrypt/cli.ini but could also be $XDG_CONFIG_HOME/letsencrypt/cli.ini (or ~/.config/letsencrypt/cli.ini if $XDG_CONFIG_HOME ) Or could be in the specific config file for a specific cert.


#5

XDG_CONFIG_HOME is not set, as far as I can see.
there was no cli.ini until today I was trying to set an email address.
Is it possible to turn off debug using cli.ini, if so how?


#6

The default is off - so if there is nothing in the config ( and you aren’t using it on the command line ) then it’s off. ( you can set “debug = False” in the config - but as above it’s off by default)


#7

I have 8 letsencrypt log file in /var/log/letsencrypt like this one pastebin

each time certbot is run a new file is created, if there is nothing to do, then the file is usually a dozen or so lines usually something like this:

2017-01-15 05:32:24,105:DEBUG:certbot.main:Root logging level set at 30
2017-01-15 05:32:24,105:INFO:certbot.main:Saving debug log to /var/log/letsencrypt/letsencrypt.log
2017-01-15 05:32:24,106:DEBUG:certbot.main:certbot version: 0.9.3
2017-01-15 05:32:24,106:DEBUG:certbot.main:Arguments: [’-q’]
2017-01-15 05:32:24,107:DEBUG:certbot.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#apache,PluginEntryPoint#webroot,PluginEntryPoint#null,PluginEntryPoint#manual,PluginEntryPoint#standalone)
2017-01-15 05:32:24,120:INFO:certbot.renewal:Cert not yet due for renewal
2017-01-15 05:32:24,122:INFO:certbot.renewal:Cert not yet due for renewal
2017-01-15 05:32:24,124:INFO:certbot.renewal:Cert not yet due for renewal
2017-01-15 05:32:24,127:INFO:certbot.renewal:Cert not yet due for renewal
2017-01-15 05:32:24,129:INFO:certbot.renewal:Cert not yet due for renewal
2017-01-15 05:32:24,129:DEBUG:certbot.renewal:no renewal failures
however if there is work to be done the pastbin example is fairly typical.


#8

did as you suggested, set debug=false, now I get nothing, not even the vaguely useful INFO messages.


#9

What info do you actually want ? (maybe answered on your other thread with the --renew-hook)


#10

Yes, the renew hook looks as though it will help with want I want to do.
But I would still like to limit the size of log files.


#11

I was wrong, setting debug = False has done nothing, still getting debug info up to my ears.


#12

And setting “debug = no” produces the same none result.
the CLI is being read, just doesn’t seem to have any effect!


#13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.