Trying to run certbot - randomly says "Killed"

My domain is: valchrom.ut.ee

I ran this command:
certbot --nginx --non-interactive --agree-tos -m jtalviste@gmail.com

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
Killed

My web server is:
nginx version: nginx/1.18.0

The operating system my web server runs on is :
alpine
NAME="Alpine Linux"
ID=alpine
VERSION_ID=3.11.6
PRETTY_NAME="Alpine Linux v3.11"

I can login to a root shell on my machine

I'm using a control panel to manage my site: no

The version of my client is certbot 1.9.0

Hi,

Can you try to monitor your system resource usage such as RAM and CPU requirement? Sometimes if you are using a VPS with striict resource limit and run over it, the script might be killed.

I tried "top" and it just shows that CPU usage and memory are OK before I start certbot. Same "Killed" messages comes when using acme-nginx. Let's say running into resource use limits is the problem. How could I solve it? Thanks.

The best way to do is to find a less resource-consuming client or to "relieve" your system before you run certbot. Do you mind to share your spec and the resource usage before start certbot?

If nothing else works, I would try reducing the complexities involved with the nginx plugin and test it manually (against the staging environment) first. And then move that up to webroot auth and certonly (also always test against staging first). Once that works, I would move that to production and just create the TLS vhost config myself.

1 Like

Hi @jtalviste

additional: May be another client like acme.sh doesn't need so much CPU etc.

My bet is on lack of memory.
Perhaps there is no swap file is in use (I would never use a swap file).