Trying to renew and being told "Your system is not supported by certbot-auto anymore"

I've seen other similar posts and im still not sure how it related to my situation. Like not clear where "snap" fits in.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
I ran this command:
sudo ./certbot-auto renew --debug

It produced this output:
Skipping bootstrap because certbot-auto is deprecated on this system.
Your system is not supported by certbot-auto anymore.
Certbot cannot be installed.
Please visit to check for other alternatives.

My web server is (include version):

The operating system my web server runs on is (include version):
NAME="Amazon Linux AMI"
ID_LIKE="rhel fedora"
PRETTY_NAME="Amazon Linux AMI 2018.03"
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot 0.24.0
certbot-auto wont give version. just says it wont run because system is not supported.


Welcome Back to the Let's Encrypt Community :slightly_smiling_face:


The king died...
Long live the king!
[there is always a new one]

In this case, you could try another ACME client just as good or arguably better in/for your particular situation:

1 Like

Ohhhh. I was looking for aws in "web hosting service" ... because that term made sense to me. now im choosing "other linux".

So... installing snap on ec2 ... not going to so well so far.

Am I the only one using letsencrypt on an amazon ami ec2 server? It feels like there must be only a a handful of us because the main documented paths just dont work. I've looked at snap ... which looks like its not going to work. And I've looked at the other options and none of them seems like they work or did work when I tried them.

Hit the magnifying glass and search the site. [top right]

I thought you were joking about LOL.

Thats really the best option? Short of updating to Linux 2?

Probably YES

Cheers from Miami :beers:

Thanks for the blunt truth.

Miami? Dang. Im freezing in seattle. enjoy the warmth.

1 Like

Which is a good idea anyway, regardless of certbot.

how do you upgrade though? press button or reinstall?

Beats me, I don't use EC2.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.