Trying to add another cert, but Connection Refused


#1

I’ve successfully created a certificate for default web site on this server, but I am unable to do it for an additional site. Any help is appreciated. Thanks.

My domain is: test.SpecialAgent.com

I ran this command: letsencrypt.exe --test

It produced this output:

My web server is (include version):
IIS 7

The operating system my web server runs on is (include version):
Windows Web Server 2008 R2

My hosting provider, if applicable, is:
n/a

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
No


#2

Hi,

This is definitely your server-side issue…

Try visiting your site test.specialagent.com is throwing an connection refused, hense let’s encrypt validation server can’t reach your site too…

Thank you


#3

Hi @cbaker,

is there a firewall? Or only local access allowed? I don’t get a response from test.specialagent.com

Opend in a browser: No connection.


#4

Totally Unrelated to your question/problem:
https://www.ssllabs.com/ssltest/analyze.html?d=specialagent.com
https://www.ssllabs.com/ssltest/analyze.html?d=agents.specialagent.com
are in need of a security review…



image


#5

It was the firewall. The first site that worked fine was on a different ip address. I thought I had the second site set up and working correctly on the second ip address, but didn’t consider that I was only testing inside the firewall and never tested from the outside. It’s working fine now - thanks for pointing me in the right direction.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.