Trouble setting up certificate for express through nginx, fetching about:blank: error getting validation data


#1

My domain is:
rpg.goctionni.net

I ran this command:
sudo ./certbot-auto --nginx

It produced this output:
sudo ./certbot-auto --nginx
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx

Which names would you like to activate HTTPS for?
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
1: rpg.goctionni.net
2: www.goctionni.net
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel): 1
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for rpg.goctionni.net
Waiting for verification...
Cleaning up challenges
Failed authorization procedure. rpg.goctionni.net (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching about:blank: Error getting validation data

IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: rpg.goctionni.net
   Type:   connection
   Detail: Fetching about:blank: Error getting validation data

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address. Additionally, please check that
   your computer has a publicly routable IP address and that no
   firewalls are preventing the server from communicating with the
   client. If you're using the webroot plugin, you should also verify
   that you are serving files from the webroot path you provided.

My web server is (include version):
nginx 1.4.6 (Proxying to: Express 4.16.3)

The operating system my web server runs on is (include version):
Linux LinuxServ 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

My hosting provider, if applicable, is:
Not applicable

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
No


#2

I don’t have IPv6 connectivity here so I’m relying on letsdebug:

https://letsdebug.net/rpg.goctionni.net/3279

It seems you are serving a bad redirect to about:blank on your IPv6 address.

Check that your AAAA record is pointed at the correct IPv6 address for your server, and that nginx is correctly configured to listen on IPv6.


#3

Thanks; I didn’t think I had any IPv6 configured, but it seems that I do (or did anyway). I’m running my server off of my regular internet connection, which seems to not have an IPv6 address (sigh).

I’ve removed the AAAA records, and expect ill have to wait a bit for that to propagate and enable me to try again.


#4

Also, there is an redirection working… Which stop me from getting anything else than a page say (play, edit)…


#5

The play, edit thing is ‘correct’. It’s a work in progress web app for which I wanted to setup oauth authentication; which means I need to setup HTTPS.


#6

Seems removing the AAAA records worked pretty quickly and getting the certificate worked now, thanks!


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.