Trouble renewing certificate for jbmortgages.co.uk


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
Via Plesk - renew certificate

It produced this output:
Error: Could not issue a Let’s Encrypt SSL/TLS certificate for jbmortgages.co.uk .

Your domain in Plesk is hosted on the IP address(es): , but the DNS challenge used another IP address: 108.59.253.82 .
Please check the actual DNS zone of your domain and make sure that the IP addresses in the DNS zone and for the hosting are the same.
Details

Invalid response from https://acme-v01.api.letsencrypt.org/acme/authz/-zua0gqGm2l9Z-c9uD82xCXkKyCLMrxZ9isLfDSiGkA.
Details:
Type: urn:acme:error:unauthorized
Status: 403
Detail: Invalid response from http://jbmortgages.london/.well-known/acme-challenge/0QjqUkCeVY3kRoxxtDZvF6vLRrz8BfA5UWie6F6ksQM: “<!DOCTYPE HTML PUBLIC “-//IETF//DTD HTML 2.0//EN”>
<html><head>
<title>404 Not Found</title>
</head><body>
<h1>Not Found</h1>
<p”

My web server is (include version):
Linux & Plesk Oynx

The operating system my web server runs on is (include version):
Ubuntu 16.04

My hosting provider, if applicable, is:
Fasthosts

I can login to a root shell on my machine (yes or no, or I don’t know):
I don’t know - I tend to use GUI and avoid root unless absolutely neccessary

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
Plesk Onyx

Other domains on the same server, with the same IP are renewing just fine - it’s only this domain that seems to be having the problem.

Thanks in advance for your help


#2

Hi @jmgraphicdesign

you have one certificate with four domain names:

https://transparencyreport.google.com/https/certificates?cert_search_auth=&cert_search_cert=&cert_search=include_expired:false;include_subdomains:false;domain:jbmortgages.co.uk&lu=cert_search

jbmortgages.co.uk jbmortgages.london www.jbmortgages.co.uk www.jbmortgages.london

But jbmortgages.london has another ip address ( 108.59.253.82 ). So Certbot / Plesk cannot create the validation file there.

If the jbmortgages.london uses another server, you should create a certificate only with the two domain names jbmortgages.co.uk www.jbmortgages.co.uk


#3

Thank you so much - yes you’re right, I hadn’t realised the alias was still pointing to the old server!

I wouldn’t have picked up on this myself, thanks for checking and pointing it out - I changed the ip for the alias and it worked straight away :slight_smile:


#4

Yep, now

https://transparencyreport.google.com/https/certificates?cert_search_auth=&cert_search_cert=&cert_search=include_expired:false;include_subdomains:true;domain:jbmortgages.co.uk&lu=cert_search

there is new new certificate.

https://transparencyreport.google.com/https/certificates/I%2B3AJ9jz1O0Yw3%2BSWy8%2Fmuo%2Fvas8UmaRl6u259ysnGQ%3D

Created today, not visible at 18:25 :wink: And already installed - https://jbmortgages.co.uk/


#5

A post was split to a new topic: Renewing the certificate on hogsellerhub.com.ng


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.