Transfer https domain to Google cloud

I’m trying to transfer the below domain from WPengine to Google VM. I’ve setup the zones as expected, but I’m experiencing this error. I didn’t initially setup the domain, I came on the project when the administrator left without a trace.

please help.

My domain is: rathe.app

I ran this command:
./certbot-auto certonly --webroot -w /var/www/ -d rathe.app -d www.rathe.app
It produced this output:

Failed authorization procedure. rathe.app (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authoriza
tion :: Invalid response from http://rathe.app/.well-known/acme-challenge/mWJDGRbySosmIvInonK7giJn9zIj42i_6cf8yqPmlgw [34.66.242.178]
: “\n\n404 Not Found\n\n

Not Found</h1
\n<p”, www.rathe.app (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid resp
onse from http://www.rathe.app/.well-known/acme-challenge/yjZwu5L3K7x2xxnFAobMgUPaAJVepgHs1ey2AzWEbEU [34.66.242.178]: “\n\n404 Not Found\n\n

Not Found

\n<p”

I’ve created the directory (.well-known/acme-challenge) in the webroot of the domain.

My web server is (include version): Apache 2.4.25

The operating system my web server runs on is (include version): Debian 9

My hosting provider, if applicable, is: Google VM

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): Not found

Hi @niran

is the full path

/var/www/.well-known/acme-challenge

If yes, create there a file (file name 1234) and try to load that file via

http://rathe.app/.well-known/acme-challenge/1234

use

./certbot-auto --version

@JuergenAuer

  1. The full path is /var/www/rathe.app/

  2. The domain redirect to https: I don’t know if this is cache issue. The zones have been updated to google cloud. Running “host rathe.app” shows the domain now point to google cloud vm.

When I run http://www.rathe.app, it redirects to https:// which then display error connecting…

Then you have to use this path as -w parameter.

No, there is no redirect ( https://check-your-website.server-daten.de/?q=rathe.app ):

Domainname Http-Status redirect Sec. G
http://rathe.app/
34.66.242.178 200 0.236 H
http://www.rathe.app/
34.66.242.178 200 0.236 H
https://rathe.app/
34.66.242.178 -2 1.350 V
ConnectFailure - Unable to connect to the remote server No connection could be made because the target machine actively refused it 34.66.242.178:443
https://www.rathe.app/
34.66.242.178 -2 1.354 V
ConnectFailure - Unable to connect to the remote server No connection could be made because the target machine actively refused it 34.66.242.178:443
http://rathe.app/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
34.66.242.178 404 0.237 A
Not Found
Visible Content: Not Found The requested URL /.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de was not found on this server. Apache/2.4.25 (Debian) Server at rathe.app Port 80
http://www.rathe.app/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
34.66.242.178 404 0.240 A
Not Found
Visible Content: Not Found The requested URL /.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de was not found on this server. Apache/2.4.25 (Debian) Server at www.rathe.app Port 80

Browsers are caching redirects, so you can't test that with a browser. If you have loaded a domain via https, the browser uses https again.

./certbot-auto certonly --webroot -w /var/www/rathe.app -d rathe.app -d www.rathe.app

may work.

1 Like

Yea, the redirects were cache related. Using curl, I got 200 response. I also created

http://www.rathe.app/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de.txt

Which clearly shows “I’m working”

My web root is structured this way

/var/www/rathe.app/html (files are served from the html directory) So i’m guessing the command would be

./certbot-auto certonly --webroot -w /var/www/rathe.app/html -d rathe.app -d www.rathe.app

Notice html after /rathe.app/

I’ll give it a try now…

2 Likes

That looks good, there is the content. Then add /html

Guess what? it worked

Your key file has been saved at:
/etc/letsencrypt/live/r/privkey.pem
Your cert will expire on 2019-08-25. To obtain a new or tweaked
version of this certificate in the future, simply run certbot-auto
again. To non-interactively renew all of your certificates, run
“certbot-auto renew”

Thank you for your prompt help. I see that the expiration is August, Can’t I use a cron to update at the set expiry date? what If i forget to renew?

2 Likes

Happy to read that it had worked.

Yes, create a cron job with the renew option.

2 Likes

Cron created and solved. Thanks

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.