TLJH HTTPS Connection is reporting as Unsecure


I have a TLJH instance setup and I want to setup HTTPS.

I ran the following commands with my domain

sudo tljh-config set https.enabled true
sudo tljh-config set
sudo tljh-config add-item

When I connect to the domain my browser tells me I can continue to the site but that the connection is unsecure. I am not sure what Im doing wrong I want to the connection to the domain to be secure.

Hi @diplo01, and welcome to the LE community forum :slight_smile:

Please help us in helping you by answering as much of the questions [that you should have been presented with when opening a "HELP" topic] below:

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):


In the meantime...
You should ensure that you took the last couple of steps:

sudo tljh-config show
sudo tljh-config reload proxy

I ran those commands and I get the following output

sudo tljh-config show
- bob

cpu: 2
memory: 8G

enabled: true

sudo tljh-config reload proxy
Proxy reload with new configuration complete

If you still get:

Then please answer the questions on post #2.


OR if that is not something you are willing to do, try:
Enable HTTPS — The Littlest JupyterHub documentation


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.