Timeout when trying HTTPS

Hi Let's Encypt community,

I have installed a wildcard certificate on my IIS 10.0 website (hosted on aws.amazon.com) and even after the binding was added succesfully, the certificate doesn't seem to work - when I request https://application.redmedsolutions.ro/redmed from my Chrome browser, the request times out and no page get's displayed. Can anybody give me a hint about what's going on?

My domain is: *.redmedsolutions.ro

I ran this command: wacs.exe as Administrator

It produced this output:

My web server is (include version): IIS 10.0

The operating system my web server runs on is (include version): Windows Server 2019

My hosting provider, if applicable, is: aws.amazon.com

I can login to a root shell on my machine (yes or no, or I don't know): yes

Thank you in advance,
John

Have you opened port 443 (TCP) in your AWS Security Group and also the Windows Firewall?

1 Like

Thank you for your suggestion _az. Even though I have opened port 443 yesterday, I checked the Inbound rules once more. I added two Inbound rules for each AWS Security group and that solved the issue. I was concerned more with the other opperations - DNS Chalenge, defining the IIS binding and so on - than with the firewall rules. Problem solved!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.