Timeout during validation

So I tried the multiple command all with the same results:

The process is failing at the verification stage with a timeout error - “The server could not connect to the client to verify the domain”

I have a Linode VPS with Debian 8 & Apache and I used the following commands:

sudo certbot --authenticator webroot --installer apache --webroot-path /var/www/html/domain.com/public_html -d domain.com -d www.domain.com

or

sudo certbot --authenticator webroot --installer apache

or

sudo certbot --authenticator standalone --installer apache --pre-hook “apachectl -k stop” --post-hook “apachectl -k start”

I also stopped the Apache server and tried the command with not success.

The server has open ports 80 and 443 and the DNS is set correctly in the DNS manager provided by Linode.

It used to work just fine with the previous version.

Can you tell me what would be the problem here? Anyone with a Linode VPS with Debian installed?

Thank you!

I’d recommend creating a new topic for your issue - this makes it easier to keep track of individual situations.

I took the liberty of splitting this into a new topic.

Timeouts like the above can be caused when you have both an AAAA record in your DNS, pointing at an IPv6 address, and an A record pointing at an IPv4 address, and the IPv6 address times out. Sometimes that can be caused by a hosting provider not routing to that address properly, or a web server not properly binding to it.

To test, you can try using curl -6 from another machine with IPv6.

Also, I strongly, strongly recommend sharing your real domain name, since it will make it much easier to help you.

2 Likes

Thank you for creating this new topic!

The domain in question is english.penmania.shop

I will ask Linode about the DNS issue you mention to see if that the case.

Let me know if you see another possible solution!

Thank you!

Razvan

@jsha’s intuition was correct. Your site advertises the IPv6 address 2a01:7e01::f03c:91ff:fe59:f331 via a DNS AAAA record—but it doesn’t work!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.