Timeout During Connect

My domain is:mscntm.tk

I ran this command:sudo certbot --apache

My web server is (include version):Apache 2.4.29 (Ubutu)

The operating system my web server runs on is (include version):Ubuntu 18.04.3 TLS - bionic

Hi @zazai

there is a check of your domain, created yesterday - https://check-your-website.server-daten.de/?q=mscntm.tk

Your www version points (via CNAME) to parkingpage.namecheap.com.

So that can’t work.

Checking the non-www version there is a timeout.

Checking the www version there are a lot of

ConnectionClosed - The underlying connection was closed: The connection was closed unexpectedly.

errors.

A working http website (open port 80) is required to create a certificate via http-validation.

Now there is a new check.

The ip addresses are now ok, no parking page.

But only timeouts.

Runs your webserver internal?

curl http://mscntm.tk/.well-known/acme-challenge/1234

should show a http status 404 - Not Found.

Perhaps there is a blocking firewall or a wrong port forward.

Thank you @JuergenAuer, I have fixed this now it is pointing to mscntm.tk, but still I get the same error.

Screenshot_4

curl : (6) could not resolve host: .well-known

There is only the www host defined. So try

curl http://www.mscntm.tk/.well-known/acme-challenge/1234

or add a ServerAlias with your non-www domain name.

PS: Checking your raw ip there is the same image - only timeouts - https://check-your-website.server-daten.de/?q=122.176.208.60

The problem has been solved, the router’s port mapping for port 80 was only to one spcific external host.

1 Like