Timeout during connect (likely firewall problem)

I’ve already tried a lot:

There is no firewall running.
Port forwarding for tcp-ports 80 und 443 is activated on my router.

I suspect two possible problems:

  1. I use a Speedport Pro from Telekom (Hybrid DSL + LTE).
  2. Strict configuration in .htaccess for Nextcloud.
  3. DynDNS-Problems. I use dynv6. There is only a AAAA-record.

My domain is:
guckuck.dynv6.net

I ran this command:
certbot renew

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/guckuck.dynv6.net.conf


Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator webroot, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for guckuck.dynv6.net
Using the webroot path /var/www/html for all unmatched domains.
Waiting for verification…
Challenge failed for domain guckuck.dynv6.net
http-01 challenge for guckuck.dynv6.net
Cleaning up challenges
Attempting to renew cert (guckuck.dynv6.net) from /etc/letsencrypt/renewal/guckuck.dynv6.net.conf produced an unexpected error: Some challenges have failed… Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/guckuck.dynv6.net/fullchain.pem (failure)


All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/guckuck.dynv6.net/fullchain.pem (failure)


1 renew failure(s), 0 parse failure(s)

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: guckuck.dynv6.net
    Type: connection
    Detail: Fetching
    http://guckuck.dynv6.net/.well-known/acme-challenge/Csg6ZeTSZHyHP9a9wi1i2jaJHTXfceeA-56NsmlT80k:
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version):
nginx/1.18.0

The operating system my web server runs on is (include version):
PRETTY_NAME=“Debian GNU/Linux bullseye/sid”
NAME=“Debian GNU/Linux”

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
certbot 1.6.0

1 Like

Hi @guckuck

there is a check of your domain, ~~45 minutes old - https://check-your-website.server-daten.de/?q=guckuck.dynv6.net

There you see the problem.

Domainname Http-Status redirect Sec. G
http://guckuck.dynv6.net/ 93.253.5.35 301 https://guckuck.dynv6.net/ Html is minified: 109,03 % 0.080 A
http://guckuck.dynv6.net/ 2003:cc:3f19:697f:b827:f524:e043:e7d4 -14 10.024 T
Timeout - The operation has timed out

Ipv4 answers, but ipv6 has a timeout.

Checking your domain Letsencrypt prefers ipv6, so that’s critical.

  • Fix your ipv6 (or)
  • remove the ipv6 AAAA record

PS: Using my webserver I can trace my current local ipv6:

tracert 2003:e9:efff:2c98:f2b0:14ff:fe0e:fe30

The same with your address - no answer:

D:\temp>tracert 2003:cc:3f19:697f:b827:f524:e043:e7d4

Routenverfolgung zu p200300cc3f19697fb827f524e043e7d4.dip0.t-ipconnect.de [2003:cc:3f19:697f:b827:f524:e043:e7d4]
über maximal 30 Hops:

1 1 ms <1 ms <1 ms fritz.box [2003:e9:ef2c:8c00:f2b0:14ff:fe0e:fe2c]
2 5 ms 18 ms 4 ms 2003:0:8003:9800::1
3 7 ms 7 ms 7 ms 2003:0:8000:d000::1
4 35 ms 33 ms 33 ms p2003000643cb1700fa084ffffe8ad1eb.dip0.t-ipconnect.de [2003:6:43cb:1700:fa08:4fff:fe8a:d1eb]
5 * * * Zeitüberschreitung der Anforderung.
6 * * * Zeitüberschreitung der Anforderung.
7 * * * Zeitüberschreitung der Anforderung.

2 Likes

Thank you for your very fast response.

After searching since hours I think I have found the problem: The telekom-router (Speedport Pro) won’t allow ipv6 traffic from external to internal. And it seams to be not possible to deactive ipv6.

I deleted the AAAA-Record at the dyndns-provider. I also deactivated ipv6 on my Raspberry Pi.

But it is not possible to renew the certificate. Now I get the following error:
IMPORTANT NOTES:

1 Like

There

is your error. Change that.

2 Likes

Can you give me another hint? Please. :slight_smile:

1 Like

So, I did it.

In den Config for my Nextcloud I added the following lines:
/etc/nginx/sites-available/default

location ~ ^/.well-known/acme-challenge/* {
        allow all;
}

Thanks for your help.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.