There were too many requests of a given type :: Error finalizing order :: too many certific ates already issued for exact set of domains:t


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: marektinglab.biz

I ran this command: sudo nano /opt/bitnami/apps/wordpress/htdocs/wp-config.php
SSLCertificateFile “/etc/letsencrypt/live/marketinglab.biz/cert.pem”
SSLCertificateKeyFile “/etc/letsencrypt/live/marketinglab.biz/privkey.pem”
SSLCertificateChainFile “/etc/letsencrypt/live/marketinglab.biz/fullchain.pem”

It produced this output: Website down. HTTP ERROR 500

My web server is (include version): Not sure

The operating system my web server runs on is (include version): Ubuntu 16.04.4 LTS (GNU/Linux 4.4.0-1060-aws x86_64)

My hosting provider, if applicable, is: Lightsail

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No. I’m using Lightsail


#2

Hi,

What’s the issues here?

Thank you


#3

Hi,

I was learning how to install Letsencrypt on Lightsail. Tried a few times until I hit the cert limit. Didn’t get the cert and now my site is down. :frowning:


#4

Hi,

As of now… Do you still have the original certificate?
If not, you might need to find a way to bypass the “exact set” restrictions. Else, you’ll need to wait for 7 days (or less) before retry.

Also, could you start your webserver?

Error 500 is a photo error, not a web server related one.

Thank you


#5

Thanks.

I can start my webserver. After I enter:
SSLCertificateFile "/etc/letsencrypt/live/marketinglab.biz/cert.pem"

SSLCertificateKeyFile "/etc/letsencrypt/live/marketinglab.biz/privkey.pem"

SSLCertificateChainFile "/etc/letsencrypt/live/marketinglab.biz/fullchain.pem"

on wp-config, my website is not working.

Here’s the cert I have.


#6

Huh? Your SSL configuration does not belong in wp-config.php.

You probably broke your WordPress installation by doing that. Undo it.


#7

Oh no…
What is the command that I should use to install

SSLCertificateFile “/etc/letsencrypt/live/marketinglab.biz/cert.pem”

SSLCertificateKeyFile “/etc/letsencrypt/live/marketinglab.biz/privkey.pem”

SSLCertificateChainFile “/etc/letsencrypt/live/marketinglab.biz/fullchain.pem”


#8

That goes in your Apache configuration.

grep -iR sslcertificatefile /etc/apache2

#9

Thanks. It says no such file


#10

Well, wherever your Apache configuration files are on your Lightsail server, that’s what you’ll need to update.

It might be somewhere in /opt/bitnami. Check the Bitnami docs for SSL.


#11

Thanks a lot. Let me try it out later.


#12

I tried running ./certbot-auto certonly marketinglab.biz but can’t retrieve the cert. Not sure what’s wrong.

Requesting to rerun ./certbot-auto with root privileges…
usage:
certbot-auto [SUBCOMMAND] [options] [-d DOMAIN] [-d DOMAIN] …

Certbot can obtain and install HTTPS/TLS/SSL certificates. By default,
it will attempt to use a webserver both for obtaining and installing the
certificate.
certbot: error: unrecognized arguments: marketinglab.biz


#13

Hi,

The command should be ./certbot-auto certonly -d marketinglab.biz (-d before each domains)

Thank you


#14

Thanks a lot. But still can’t find the directory. Wonder what has went wrong.

bitnami@ip-172-26-11-137:~ ./certbot-auto certonly -d marketinglab.biz -bash: ./certbot-auto: No such file or directory bitnami@ip-172-26-11-137:~ ./certbot-auto certonly -d www.marketinglab.biz
-bash: ./certbot-auto: No such file or directory


#15

The ./ notation means to execute from the current directory. You have to be in the same directory as certbot-auto for that to work.


#16

Haiz… I’m actually quite lost. Is there any way that I can delete everything and restart the process again? Seems like I have done something wrong somewhere. Fixing it will be more time consuming.

Here’s a snapshot of the SLL cert info which I can’t configure correctly.


#17

I notice the SSL that I installed is under example.com. I don’t know how to remove these. Anyone can help?


#18

Hi @calvinongstudio

your domain https://marketinglab.biz/ uses a self signed certificate, named “example.com”, not a certificate with the domain name marketinglab.biz.


#19

Thanks for pointing.

How can I reverse/ delete or reinstall it? When I try to reinstall it, it says I hit the certificate limit.


#20

You have a lot of certificates, see your own post:

And you have files:

So use them in your Apache - configuration. See

https://httpd.apache.org/docs/2.4/ssl/ssl_howto.html

Listen 443
<VirtualHost *:443>
    ServerName www.example.com
    SSLEngine on
    SSLCertificateFile "/path/to/www.example.com.cert"
    SSLCertificateKeyFile "/path/to/www.example.com.key"
</VirtualHost>