There was a problem processing your request

When I try to issue an Wildcard certificate I got following issue..

There was a problem processing your request

  • Error issuing certificate
  • Failed to issue certificate
  • Could not add TXT record

Most certificates stopped before renewal date or give issues when automatic renewal is processed.

Thnx in advance!


our vps server is

1 Like

I've moved your thread to the #help section, as I'm thinking your thread is more about getting help with issuance than you'd like to discuss something about issuance.

In the #help section, you would have been provided with a questionnaire, which is mandatory to fill out to get proper support. While you've already given us some answers, I'd like to invite you to answer all the questions nonetheless as good as you can. If you don't know the answer to a question directly, please say so in stead of leaving it blank. Here's the questionnaire:

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):


This is probably the important part. Whichever ACME client you are using is trying to use DNS validation (updating your domain's DNS with an _acme-challenge TXT record to prove you control that domain). You need to look at how that is configured and that will depend on what tool you are using to get certificates.

1 Like

This error means that the cPanel account in question does not have the right permissions to be able to modify their own DNS records.

If you're the admin of the VPS, you can fix this:

Make sure that the Zone Editor (AAAA, CAA, SRV, TXT) feature is enabled WHM Feature Manager for each package that you want to be able to use DNS validation.

Remember also that the domain needs to be using the cPanel nameservers, not external ones.


It there any way how I can check the really cause of this issue? I'm desperate in this case, can't get it resolved.. Has Let's Encrypt a paid service to get this solved?

Hi @rubberduck,

Did you make the relevant change in WHM Feature Manager?

Are you the root admin of your cPanel server?

Yes this feature was always enabled..


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.