The site, https, is showing as insecure, http, OK

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain

I ran this command:

It produced this output:ERR_CONNECTION_REFUSED

My web server is (include version):Ubuntu 18.04.4 Apache/2.4.29

The operating system my web server runs on is (include version):Ubuntu 18.04.4 Apache/2.4.29

My hosting provider, if applicable,

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):certbot 0.31.0

1 Like

Hi @Adauto

your certbot command is required. And the output of that command. If there is no certificate created, the result is expected.

1 Like

Hi JuergenAuer, some hours ago, I added Letsencrypt to,, it took just a few minutes, but the site is showing as insecure:

IMPORTANT NOTES: certbot 0.31.0

  • Congratulations! Your certificate and chain have been saved at:
    Your key file has been saved at:
    Your cert will expire on 2020-08-24. To obtain a new or tweaked
    version of this certificate in the future, simply run certbot
    again. To non-interactively renew all of your certificates, run
    “certbot renew”

Hi JuergenAuer, after I ran the certbot command:
root@mybox:~# certbot
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
No names were found in your configuration files. Please enter in your domain
name(s) (comma and/or space separated) (Enter ‘c’ to cancel):
Cert not yet due for renewal
You have an existing certificate that has exactly the same domains or certificate name you requested and isn’t close to expiry.
(ref: /etc/letsencrypt/renewal/
What would you like to do?

1: Attempt to reinstall this existing certificate
2: Renew & replace the cert (limit ~5 per 7 days)

Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel): c
Operation canceled.

Thanks, Adauto

1 Like


is your job.

A working port 80 vHost is required, so Certbot can use that vHost as template to create a port 443 vHost.

Add one. Your documentation has samples.


Thanks JuergenAuer, I did that and reinstalled the domain, it’s working OK now, thanks, Adauto


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.