The site continues without https: //


#1

Hello,

I checked acme.sh and received the certificate. However, my site is still without https: //

I use Nginx and Centos 7.

I also made the verification via txt cloudflare, but it continues without https


#2

What did you do to install the certificate? And why did you categorize this post as a feature request?


#3

Hi,

Also, what’s your domain name?
Did you install your certificate to your web server?
More importantly, is your site not working with https or there is no padlock?

Thank you
#moved to #help #


#4

Check this project: https://github.com/Neilpang/get.acme.sh

Install ACME.sh

$ curl https://get.acme.sh | sh

Key Cloudflare https://github.com/Neilpang/acme.sh/blob/master/dnsapi/README.md

$ export CF_Key=“sdfsdfsdfljlbjkljlkjsdfoiwje”
$ export CF_Email="xxxx@sss.com"
$ acme.sh --issue --dns dns_cf -d example.com -d www.example.com

Sorry, I put it on the wrong topic. Can you fix this?


#5

So you did nothing to install the certificate, or configure your server to speak HTTPS? Then there’s your problem.


#6

My domain is: lserpes.com

I installed it on my web server (nginx), but the padlock does not appear and neither is https: //


#7

Hi,

It’s https & it’s on CloudFlare…
See:

The issue is wordpress is not picking up https…
You would need to go to your wp admin panel -------> Settings and change Both URL to https…

Thank you


#8

I have already installed it by different methods and apparently the certificate is generated successfully. However, the site remains the same. You see?


#9

Generating the certificate and configuring your webserver to use it are two different things, and as far as I know, acme.sh doesn’t do the latter.


#10

I would like to repeat…

You are using CloudFlare’s free CDN service… The certificate shown would always be CloudFlare’s universal certificate.

Even if you installed the let’s encrypt certificate, despite the fact that Let’s Encrypt certificate will only secure the connection between your server & Cloudflare, your site is not working properly on https.

You must ask WordPress to stop using the http link and start using https!

Steps to do it:

  1. Login to your wordpress admin panel http://lserpes.com/wp-login.php?redirect_to=http%3A%2F%2Flserpes.com%2Fwp-admin%2Foptions-general.php

  2. After you logged in, you should be directed on to “General Settings”

  3. Replace the two link show in Wordpress Address & Site Address with https protocol.

  4. Click the Save Changes button.

  5. Refresh your site.

It should be working properly in https. If not, clear your cache.


#11

I’ll correct it now and let you know. Thank you


#12

The site has entered Loop. Too_many_redirects


#13

Hi,

What did you set on the site URL and WordPress URL?

Thank you


#14

https://www.lserpes.com
https://www.lserpes.com


#15

Hi,

Please take a look at this article

Please also take a look at your CloudFlare settings… Check if that have any redirections set.

Thank you


#16

I probably have to add a redirect to / etc / nginx / sites-available / default

Redirect

server {

listen 80;
server_name example.com www.example.com;

return 301 https: //www.example.com$request_uri;

}


#17

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.