The Let's Encrypt HTTP challenge failed: acme error 'urn:acme:error:connection':

HI,

We are using cpanel version 11.58

I ran this command:

le-cp ssl --user=neurothe issue neuro-english.eu

It produced this output:

Failed to get certificate for map[neuro-therapy.eu:{neuro-therapy.eu neuro-therapy.eu Addon /home/neurothe/neuro-therapy.eu neurothe}]: The Let’s Encrypt HTTP challenge failed: acme error ‘urn:acme:error:connection’: DNS problem: SERVFAIL looking up A for neuro-therapy.eu, aborting

The same error is displayed when we try to issue LE cert for neuro-english.eu .

The DNS settings for both domains are ok .

Regards

The Let’s Encrypt validation servers use Google Public DNS, which enforces DNSSEC. (See the correction below.)

The DS records for both your domains are incorrect. You must obtain the correct DS records for each domain from your DNS provider and update them with your domain registrar. Alternatively, you can disable DNSSEC with your domain registrar, but since your DNS provider does support DNSSEC, it is better to just fix it.

You can use dnsviz.net to see the problem and confirm it has been resolved.

You’re half right! We don’t use Google Public DNS but we do enforce DNSSEC.

Thanks for pointing out the DS record errors!

Sorry, I misinterpreted a post from a staff member in another thread where they had merely reproduced a DNSSEC issue using Google Public DNS.

Thanks for the correction, and many more thanks for this awesome thing that you work on. :heart_eyes:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.