The certificate is not trusted because it is self-signed


#1

Hi - details as required below. Background: The certificate was working i…e, I could load the site under HTTPS without problems, until I migrated the site behind a router. I was trying to setup ports to accomodate various systems (I hadn’t realized LE is forced to use 443). Now both 443 and 80 are forwarded to the server (a nexctloud install as below). The site started giving errors (as above). So I tried to reinstall my certificates manually - using the “extend” option. This included manually making the acme challenge folder and file (using the data Letsenecrypt provided). When this didn’t work i.e., same error. I uninstalled, purged letsencrypt and started again. As this point - LE - reports my certificates are installed. The -le-ssl file has also be remade. However I’m still getting the above error in Firefox when I try and load the site.
I would be grateful for any help to fix up my screw-up. Thanks!

My domain is: stanworth.cloud

I ran this command: https://stanworth.cloud (in my browser)

It produced this output: The certificate is not trusted because it is self-signed.

My web server is (include version): apache2

The operating system my web server runs on is (include version): ubuntu 16.04

My hosting provider, if applicable, is: n/a

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


#2

https://stanworth.cloud/ seems to be the control panel for a Cisco RV345 router.

Are the DNS records correct?

Are the port forwarding settings correct?


#3

Well that was fast.
Thanks for that- brought on a big laugh - after lots of hours of tearing my hair out. I just couldn’t figure out where the certificate was coming from.
Yes - the router was also running on 443. After changing that port I’m reaching the server (securely) just fine.
Thanks very much. Sorry for that silly mistake.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.