# The Certificate Authority failed to verify the temporary nginx configuration changes made by Certbot. Ensure the listed domains point to this nginx server and that it is accessible from the internet

**URL:** <https://community.letsencrypt.org/t/the-certificate-authority-failed-to-verify-the-temporary-nginx-configuration-changes-made-by-certbot-ensure-the-listed-domains-point-to-this-nginx-server-and-that-it-is-accessible-from-the-internet/194693>\
**Category:** Help\
**Created:** [March 17, 2023, 12:12pm UTC](https://community.letsencrypt.org/t/the-certificate-authority-failed-to-verify-the-temporary-nginx-configuration-changes-made-by-certbot-ensure-the-listed-domains-point-to-this-nginx-server-and-that-it-is-accessible-from-the-internet/194693 "2023-03-17T12:12:41Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![peaky76](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/peaky76/32/68654_2.png) [@peaky76](https://community.letsencrypt.org/u/peaky76)\
**Post date:** [March 17, 2023, 12:12pm UTC](https://community.letsencrypt.org/t/the-certificate-authority-failed-to-verify-the-temporary-nginx-configuration-changes-made-by-certbot-ensure-the-listed-domains-point-to-this-nginx-server-and-that-it-is-accessible-from-the-internet/194693/1 "2023-03-17T12:12:41Z")

</div>

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. [crt.sh | example.com](https://crt.sh/?q=example.com)), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: [www.theweereview.com](http://www.theweereview.com)

I ran this command: sudo certbot renew

It produced this output:

* * *

Processing /etc/letsencrypt/renewal/theweereview.com.conf

* * *

Renewing an existing certificate for [theweereview.com](http://theweereview.com) and [www.theweereview.com](http://www.theweereview.com)

Certbot failed to authenticate some domains (authenticator: nginx). The Certificate Authority reported these problems:  
Domain: [www.theweereview.com](http://www.theweereview.com)  
Type: unauthorized  
Detail: 2a03:b0c0:1:d0::beb:1: Invalid response from [http://www.theweereview.com/.well-known/acme-challenge/Fhnr6JRpRrzqHmZjtYGmwrgQVhcmrcaVN3SmRxwDTck:](http://www.theweereview.com/.well-known/acme-challenge/Fhnr6JRpRrzqHmZjtYGmwrgQVhcmrcaVN3SmRxwDTck:) 404

Hint: The Certificate Authority failed to verify the temporary nginx configuration changes made by Certbot. Ensure the listed domains point to this nginx server and that it is accessible from the internet.

Failed to renew certificate [theweereview.com](http://theweereview.com) with error: Some challenges have failed.

* * *

The following certificates are not due for renewal yet:  
/etc/letsencrypt/live/theweereview.com-0001/fullchain.pem expires on 2023-06-15 (skipped)  
All renewals failed. The following certificates could not be renewed:  
/etc/letsencrypt/live/theweereview.com/fullchain.pem (failure)

* * *

1 renew failure(s), 0 parse failure(s)  
Ask for help or search for solutions at [https://community.letsencrypt.org](https://community.letsencrypt.org). See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version): nginx/1.18.0 (Ubuntu)

The operating system my web server runs on is (include version):

Distributor ID: Ubuntu  
Description: Ubuntu 22.04.1 LTS  
Release: 22.04  
Codename: jammy

My hosting provider, if applicable, is: Digital Ocean

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of `certbot --version` or `certbot-auto --version` if you're using Certbot): 2.4.0

---

<div class="post-metadata">

**Author:** ![MikeMcQ](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/mikemcq/32/52772_2.png) [@MikeMcQ](https://community.letsencrypt.org/u/MikeMcQ)\
**Post date:** [March 17, 2023, 1:25pm UTC](https://community.letsencrypt.org/t/the-certificate-authority-failed-to-verify-the-temporary-nginx-configuration-changes-made-by-certbot-ensure-the-listed-domains-point-to-this-nginx-server-and-that-it-is-accessible-from-the-internet/194693/2 "2023-03-17T13:25:48Z")

</div>

> [@peaky76](#):
>
> Detail: 2a03:b0c0:1:d0::beb:1: Invalid response from [http://www.theweereview.com/.well-known/acme-challenge/Fhnr6JRpRrzqHmZjtYGmwrgQVhcmrcaVN3SmRxwDTck:](http://www.theweereview.com/.well-known/acme-challenge/Fhnr6JRpRrzqHmZjtYGmwrgQVhcmrcaVN3SmRxwDTck:) 404

That is an IPv6 address in the error message. You have both IPv4 and IPv6 addresses in your DNS but the IPv6 seems wrong. It returns a different result to HTTP request than your IPv4 address.

Make sure that is the correct IPv6 address or remove it from your DNS

> **[Test result for www.theweereview.com: Warning](https://letsdebug.net/www.theweereview.com/1410946)**
>
> 1 unique issue(s) detected (MultipleIPAddressDiscrepancy)

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/letsencrypt/original/3X/c/a/ca6c06ea1ea201324bba7048c6841ce60236468d.png) [@system](https://community.letsencrypt.org/u/system)\
**Post date:** [April 16, 2023, 1:26pm UTC](https://community.letsencrypt.org/t/the-certificate-authority-failed-to-verify-the-temporary-nginx-configuration-changes-made-by-certbot-ensure-the-listed-domains-point-to-this-nginx-server-and-that-it-is-accessible-from-the-internet/194693/3 "2023-04-16T13:26:47Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
