Suppress saving debug log message

Hi,

everytime I run the ./certbot-auto certificate command I am seeing a
“Saving debug log to /var/log/letsencrypt/letsencrypt.log”
if I use -q it suppresses everything including the list of domains and if the date is valid.

Is there anyway I can just suppress the saving debug log message?

1 Like

Hi @ToddG,

It looks like -q is the only option certbot currently has for adjusting the level of output. However, maybe with some additional information, we could find a work-around.

For example, if you are sure you don’t care about any stderr output from certbot, then redirecting it to /dev/null would work:
./certbot-auto certificates 2>/dev/null

1 Like

Ok, that worked perfectly. Thank you, I tried something similar, but it was still outputting the log message, and the 2nd one, didn’t output anything.

Thank you very much!

2 Likes