Suddenly Certbot Stop Working - Some challenges

Hello Team,

linkjoy product helps users to create shorten their links. User can add their domain as custom domain in linkjoy. So they can use their domains to create short links.

So, First users have to add CNAME of linkjoy in their DNS and then they have to add domin in our platform. When users add domin, we generate Nginx file for that domain and generate SSL through "sudo certbot --nginx -n --redirect -d domain_name" command. All this is done with PHP script in queue (We use laravel)

This is working fine for around 230 domains. But suddenly certbot stop working without any changes in code, server or nginx configuration.

When we run "sudo certbot --nginx -n --redirect -d domain_name", we got following error.

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
Waiting for verification...
Challenge failed for domain
http-01 challenge for
Cleaning up challenges
Some challenges have failed.


Now, this happens with every new domain and even get the same error when we try to renew the old certificates.

Please help us to fix this error.

My domain is:

I ran this command:

It produced this output:

My web server is (include version): nginx/1.18.0

The operating system my web server runs on is (include version): Ubuntu 20.04.1 LTS

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 0.40.0

Hi @haryvincent176 and welcome to the LE community forum :slight_smile:

Have you made any progress?
I am unable to replicate the "Route Not Found" error.

1 Like

@haryvincent176 Your post looks the same as one from Sept 1. Did you ever get it working after that? You did not respond to @rg305 after his last post there.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.