Starting from scratch


#1

Please fill out the fields below so we can help you better.

My domain is: codecreations.co

I ran this command: $ brew install certbot

It produced this output: Cant remember, but it told me it couldnt get my certificate and couldnt connect to my site

My operating system is (include version): MAC OSX Sierra 10.12.2

My web server is (include version): not a clue… Cpanel? Linux ?

My hosting provider, if applicable, is: GoDaddy

I can login to a root shell on my machine (yes or no, or I don’t know): Not a clue, i dont think so (no SSH)

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): YES, Cpanel

I dont know how to do this the documentation is so confusing!


#2

It depends on exactly what your account is with GoDaddy. Most of the cheaper, shared hosting, cpanel hosting accounts GoDaddy do not allow you to install your own certificate. So we can talk you through obtaining a certificate, I’d suggest checking with GoDaddy first though that, if you obtain a certificate. can you install it on the account.


#3

Read a lot on their communities about people not being able to use LE on GoDaddy, probably too scared to lose sales of their own SSL certs. Had to go there because of a problem with the .hosting registry and a domain I purchased and saw lots of posts there about LE.


#4

@joebentaylor

what are you trying to achieve?

HTTPS version of your current site?

If so give us an idea what we are working with

A) Are you using GoDaddy WebHosting Services?
B) Do you have a control panel (i have not used godaddy for a while but i remember there used to be an interface to manage certificates)
C) there are lots of clever people on this forum who can help so please explain the problem and I am sure someone will have a good solution


#5

also seems like you have a LetsEncrypt cert installed now

if you can share how you got there it would be useful for others


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.