SSL Not working in all domains

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: crm.infysec.com,portal.digialert.com,crm.vinodsenthil.com,crm.harry-productions.com

I ran this command:
i am using one hosting for all the sub domains.
last few days i cant renewal the crm.infysec.com domain, other domains are works well in that time.

today i tried to delete the certificate ( crm.infysec.com ) domain

after restart the server, its getting the ssl issue for all sub domains

these are the following commands are ran

  1. sudo certbot delete --cert-name crm.infysec.com

It produced this output:

apache server is working fine.

now ssl not working in all domains

My web server is (include version): apache/2.4.52

The operating system my web server runs on is (include version): ubuntu 22.04

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.21.0

Can you show us your Apache virtualhost config?

2 Likes

You should comment out the redirect permanent ... in the port 80 VirtualHost for your crm.infysec.com domain. It sends all HTTP requests to HTTPS but the HTTPS VirtualHost is broken because it has no certificates defined.

But, I don't see why that would affect all your other VirtualHosts. What does this show

sudo apache2ctl -t -D DUMP_VHOSTS
5 Likes

duplicate limit exceeded ,

Below is a duplicate name:port
image

And another one:

And one more:
image

3 Likes

And this one has no matching HTTP vhost:
image

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.