SSL Fail and auto redirect after restart server


#1

Hello every body, Someone help me. I used SSL certbot (apache), I installed success. But, today i config in file my.cnf of MySql, after I restart apache (sudo /etc/init.d/apache2 restart) again. Now, i can’t not access my domain and auto redirect GitLab. Thanks for watch.

My domain is: xxx
I ran this command: sudo /etc/init.d/apache2 restart . After config my.cnf
It produced this output: no output info, then i access again but login fail
My web server is (include version): Ubuntu 16.04 Apache2 PHP7 MySQL 5
The operating system my web server runs on is (include version): Ubuntu 16.04 Apache2 PHP7 MYSQL 5.
My hosting provider, if applicable, is: RDS of AWS.
I can login to a root shell on my machine (yes or no, or I don’t know): yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Transmit

I access my domain and auto redirect gitlab. don’t access phpmyadmin.
Thanks You.


#2

Please fill out the questions you deleted when you created this topic. We really do need answers to those to help you. For the “command you used” question, please put the Certbot command you used to issue this certificate. It should be in your command history.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#3

Thanks guy. I fixed my topic again. Hope you can help me.


#4

Hi,

I’m not sure how editing my.cnf for mysql could impact your apache…

Since it looks like apache is having trouble starting up, can you try the following command and share us the output?

apachectl fullstatus
apachectl configtest

--------------------------------- (If apachectl returns not found, try the following)

apache2ctl fullstatus
apache2ctl configtest

Thank you


#5

root@ip-xxx-xx-xx-xx:~# apachectl fullstatus
/usr/sbin/apachectl: 101: /usr/sbin/apachectl: www-browser: not found
‘www-browser -dump http://localhost:80/server-status’ failed.
Maybe you need to install a package providing www-browser or you
need to adjust the APACHE_LYNX variable in /etc/apache2/envvars
root@ip-xxx-xx-xx-xx:~# apachectl configtest
Syntax OK

Thanks you.


#6

Hi,

If this is syntax OK, can you please try thissystemctl restart apache or service apache restart?

I’m not sure why apache suggest www-browser, but if you want to remove this message, just install a package called links (I have no idea what impacts will have if you install that package) (Do it in your own risk)

Thank you


#7

Thanks you. I search google and same result install package Links :smile: thanks for support


#8

Hi Guy, I installed Links but still old error.

I run command : ‘systemctl restart apache’ or ‘service apache restart’. after i have notification Failed to restart apache.service: Unit apache.service not found.

Run command: “sudo service apache2 status” =>>>>

apache2.service - LSB: Apache2 web server
Loaded: loaded (/etc/init.d/apache2; bad; vendor preset: enabled)
Drop-In: /lib/systemd/system/apache2.service.d
└─apache2-systemd.conf
Active: inactive (dead) since Thu 2018-07-12 03:55:23 UTC; 6min ago
Docs: man:systemd-sysv-generator(8)
Process: 21305 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
Process: 21286 ExecStart=/etc/init.d/apache2 start (code=exited, status=0/SUCCESS)

Jul 12 03:55:23 ip-172-31-25-180 apache2[21286]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:443
Jul 12 03:55:23 ip-172-31-25-180 apache2[21286]: (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:443
Jul 12 03:55:23 ip-172-31-25-180 apache2[21286]: no listening sockets available, shutting down
Jul 12 03:55:23 ip-172-31-25-180 apache2[21286]: AH00015: Unable to open logs
Jul 12 03:55:23 ip-172-31-25-180 apache2[21286]: Action ‘start’ failed.
Jul 12 03:55:23 ip-172-31-25-180 apache2[21286]: The Apache error log may have more information.
Jul 12 03:55:23 ip-172-31-25-180 apache2[21286]: *
Jul 12 03:55:23 ip-172-31-25-180 apache2[21305]: * Stopping Apache httpd web server apache2
Jul 12 03:55:23 ip-172-31-25-180 apache2[21305]: *
Jul 12 03:55:23 ip-172-31-25-180 systemd[1]: Started LSB: Apache2 web server.


#9

Hi,

This means that something is taking the port 443. (SSL) so Apache can’t bind…

Try this command
sudo lsof -i -n -P | grep 443 (this will list the service binds to port 443)

Thank you


#10

I think gitlab. Do can show me the way change gitlab? Thanks stevenzhu
nginx 26390 root 7u IPv4 1457540 0t0 TCP *:443 (LISTEN)
nginx 26391 gitlab-www 7u IPv4 1457540 0t0 TCP *:443 (LISTEN)


#11

Man…

You are having another Nginx instance…

One really fast way of doing this will be move your Apache vHosts to Nginx and remove Apache. (Only use Nginx)

Since I have no idea what that Nginx serves…


#12

I only use apache for server. I not install Nginx and my domain auto redirect Gitlab. So, I don’t know way remove gitlab-www :frowning: I think it does not affect.


#13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.