SSL certificate thowing error on Mobile Network

My domain is:

I have set a Django host on Ubuntu 18.04 with Nginx, Gunicorn. Then I set up my certbot to install Let’s encrypt SSL. It is working fine with both Desktop and Mobile over wifi network. But when I switch to Mobile Network it says :

The page you are trying to view can not be shown because the authenticity of the received data could not be verified.

Here is SSL Lab report :

These are the instructions from DigitalOcean I followed :

Hi @Yunus0or1

the main things are ok.

Your certificate has both domain names ( ):
expires in 90 days, - 2 entries

there are no chain errors

Chain (complete)	
	2	CN=Let's Encrypt Authority X3, O=Let's Encrypt, C=US

and both connections are secure.

Domainname Http-Status redirect Sec. G -14 10.024 T
Timeout - The operation has timed out -14 10.027 T
Timeout - The operation has timed out 200 3.026 I 200 2.813 I

But there is no port 80 and no redirect http -> https, that’s bad.

And your https has some content problems.

But not mixed content, only missing files.

So there is no really critical problem visible.

Do you have a screenshot?

Sir, my server is currently up. You can use your Desktop browser to visit it. Also you can use your mobile phone browser to hit the server. Here is the screenshot

1 Like

Also I have redirected http - > https

1 Like

I can’t visit your site on desktop firefox

1 Like

1 Like

just tried it with Firefox mobile 67.03 and connection is secured by Letsencrypt. The site is extremely slow to load. Also it does not work at all on http (whatever the network)

1 Like

The redirect is missing, there is no http answer.

But the site works.

Desktop and mobile (Wlan).

Perhaps refresh your page.

PS: Checked mobile with FF 67.0.3, same with mobile Chrome.

The server is hosted using a local ISP. So it can be slow. Thanks for the feedback sir.

1 Like

Is it then because my mobile network does not contain let’s encrypt as SSL provider ? I have tried two different mobile networks both replied the same.

1 Like

I don’t know. There are no details.

Is it possible that you install mobile Firefox or Chrome?

Or is your browser / device too old?

There is a new check of your domain via SSLLabs - - Grade A, that’s good.

Tested on Samsung Note 9 and Samsung galaxy s5. Somehow both showed the same result. :’(

1 Like

Dear mentors : I have found out that the issue is related about Nginx and cert not redirecting HTTP request to HTTPS. I would humbly request you to visit my new question.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.