SSL Certificate on 2 Domains


#1

My domain is: teamquantos.net

I ran this command: ./certbot-auto

It produced this output:

My operating system is (include version): Debian 8 Jessie

My web server is (include version): Apache2

My hosting provider, if applicable, is: Webtropia

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

So, I wanted to activate an SSL certificate on teamquantos.net but I could only choose “mail.teamquantos.net” and I don’t know how to fix that. I’d like to have the SSL on my main Domain “teamquantos.net

~ asdf1414


#2

using it is “auto” like that it will read whatever vhosts you have in your apache config … do you have a vhost for teamquantos.net ?

If not, you can always use webroot or one of the other methods to define exactly which domains you want certificates for


#3

How do I actually do that. I don’t know any commands except of ./certbot-auto :’)
And I don’t use any vhosts


#4

The documentation is at https://certbot.eff.org/docs/using.html#getting-certificates-and-choosing-plugins

You can use something like

certbot certonly --webroot -w /var/www/ -d teamquantos.net -w /var/www/mail -d mail.teamquantos.net

if your main teamquantos.net is in /var/www and mail.teamquantos.net is in /var/www/mail


#5

It’s telling me "-bash: certbot : Command not found
I installed certbot before with this commands https://certbot.eff.org/#debianwheezy-apache
because It wasn’t working with the Installation guide for Debian 8.


#6

It depends how you installed it.

Try putting the two characters “./” in front of the command ( so it’s ./certbot ) in the same folder as you installed certbot. If that fails, try with certbot-auto or let us know how you installed it.


#7

It’s not working with ./certbot…
And certbot-auto was the first command I tried with.
And how I installed: See upper post


#8

In the first post you said you used “./certbot-auto” not just certbot-auto hence why I asked you to (in the same directory) run it with the ./ on the front

so I made 2 suggestions in the previous post

./certbot certonly --webroot -w /var/www/ -d teamquantos.net -w /var/www/mail -d mail.teamquantos.net

and

./certbot-auto certonly --webroot -w /var/www/ -d teamquantos.net -w /var/www/mail -d mail.teamquantos.net

did they both fail ?

By “how you installed it?” I mean did you install using apt ? git ? copyting the file with wget or curl ? … how specifically did you install certbot ?


#9

Yes, they both failed and I used wget https://dl.eff.org/certbot-auto


#10

what directory were you in when you did the “wget” ? you need to go to that same directory


#11

Yes. I installed it in ~/build and also used the commands where I’ve been in this directory


#12

well the ./certbot-auto command ran for you earlier - so it seems odd that it can’t now find that file to run. Have you deleted anything ?


#13

No, I didn’t delete anything


#14

then it should still be there. What does running “ls -l ~/build/” give ?


#15

total 4
drwxrwxr-x 12 root root 4096 Feb 15 11:42 mailcow-0.14

Thats in the mailcow directory:
dovecot installer.log LICENSE opendkim roundcube
fuglu install.sh mailcow.config postfix spamassassin
includes letsencrypt-sh misc README.md webserver


#16

does “whereis certbot” or “whereis certbot-auto” give an answer ?


#17

whereis certbot gives me:
certbot:

and the other gives me the same just with certbot-auto


#18

At the moment then it doesn’t appear as if you have installed certbot fully - it’s probably worth following the instructions at https://certbot.eff.org/#debianjessie-apache to install it


#19

The commands to install it for Debian 8 are not working, the first is giving me out:

E: The value ‘jessie-backports’ is invalid for APT::Default-Release as such a release is not available in the sources

So then I installed with the commands for Debian 7 and I could use ./certbot-auto


#21

@serverco, the original screenshot shows that certbot-auto is fully installed and working somewhere on the system… I think it’s still a question of figuring out where!

One option would be

find ~ -type f -name certbot-auto

That should make clear where it is. :slight_smile: