Some challenges have failed

I bought a new router for this purpose and this is my router forwarding

Port 443 has a typo, you are forwarding to 433 instead of 443 (but this should not be the issue).

Is this the only router you have online?

Did you config NPM in some weird way with raw nginx config files?

2 Likes

Oh hold on let me edit 433 to 443 and try again

still not working after editing port forwarding I copy the file by clicking on the raw tab from NPM website which never worked then from github and still never worked

Looks like a Traefik system on port 443. The http and https response headers look very similar. Where is your Traefik system running?

Cert sent for https requests

openssl s_client -connect raspslabhomer.duckdns.org:443

subject=CN = TRAEFIK DEFAULT CERT
issuer=CN = TRAEFIK DEFAULT CERT
notBefore=Jan  9 18:04:29 2024 GMT
notAfter=Jan  8 18:04:29 2025 GMT

HTTP and HTTPS requests get similar response. And, usually we would see a "Server" header if reaching a normal web server.

curl -ik https://raspslabhomer.duckdns.org
HTTP/2 404
content-type: text/plain; charset=utf-8
x-content-type-options: nosniff
content-length: 19
date: Wed, 10 Jan 2024 21:09:29 GMT

curl -i http://raspslabhomer.duckdns.org
HTTP/1.1 404 Not Found
Content-Type: text/plain; charset=utf-8
X-Content-Type-Options: nosniff
Date: Wed, 10 Jan 2024 21:07:21 GMT
Content-Length: 19

3 Likes

I first tried to install traefik as my proxy manager and I could not get it working so I uninstalled it and tried NPM. these are all my containers which are running and installed.

I don't see port 443 defined anywhere but yet your system is still replying to HTTPS requests on that port. There must be something in front of all these Containers intercepting that request.

Given the response to http on port 80 looks very much the same as port 443 I think those are being intercepted as well. I am not a portainer expert you may need to ask on their forum or wait for a different volunteer here

2 Likes

A post was merged into an existing topic: Certbot apache renewal problem

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.