[solved] Trouble with --dns-google-credentials file path


#1

Hi,

I’m a newbie and am having trouble getting this command run. I want to install a wildcard for my server. Everything look good except the result says file not found. I tried giving the google.json with different access types but still its the same.

My domain is: dev.smoothflow.io

I ran this command:

sudo docker run -it --rm --name certbot
-v “/etc/letsencrypt:/etc/letsencrypt”
-v “/var/lib/letsencrypt:/var/lib/letsencrypt”
certbot/dns-google certonly --server https://acme-v02.api.letsencrypt.org/directory
–dns-google
–dns-google-credentials /home/shehan/google.json
–dns-google-propagation-seconds 60
-d *.dev.smoothflow.io
-d dev.smoothflow.io

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator dns-google, Installer None
Obtaining a new certificate
Performing the following challenges:
dns-01 challenge for dev.smoothflow.io
dns-01 challenge for dev.smoothflow.io
Cleaning up challenges
File not found: /home/shehan/google.json

My web server is (include version): Ubuntu 15.10

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


#2

Docker containers don’t have access to your regular filesystem, except for paths you mount specifically.

For example, you can try adding:

-v "/home/shehan/google.json:/home/shehan/google.json"

#3

Thank you. that made it work.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.