SOLVED Renewal problem: incorrect well-known url?

Hi, I have several certificates on my server, almost all of them are correctly renewed, but I have a problem with one. Error says:

Attempting to renew cert from /etc/letsencrypt/renewal/ produced an unexpected error: Failed authorization procedure. (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching Error getting validation data. Skipping.

Looks like he can’t get the challenge document. As you may note, there is no / between the domain and .well-know/etc. I guess probably there is some error somewhere in my configurations, but can’t find where. Apache configuration is right (domain works); renew conf looks like the others:

[[webroot_map]] = /var/www/delosbooks/ = /var/www/delosbooks/

I forgot to say: the well-known directory has bee created correctly. He just can’t get it back via http

Where can I try to look?

Problem solved, it was a “redirect” without trailing / in apache conf.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.