[Solved] Issue with ovirt and cert

My domain is: https://vle.noroff.no/

I ran this command: I have installed ovirt version 4 and setup Lets Encrypt using certbot.

The SSL encryption is working as the Lock shows up and I have run https://www.ssllabs.com.

It produced this output: When I browse to the application, I get the following error:
sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

When I run https://www.ssllabs.com, it initially says there is a name mismatch, but I am not sure where that is or how to fix that.

My web server is (include version): Apache

The operating system my web server runs on is (include version): CentOS 7

My hosting provider, if applicable, is: self hosted

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

Edit: I had the thought that it might be related to java, so I have added Lets Encrypt to the truststore. When checking the truststore, I see the following:
let’sencryptauthorityx3, Sep 18, 2017, trustedCertEntry,
Certificate fingerprint (SHA1):

Which would indicate that it is in the Java truststore.

I got it resolved. Seems there was an issue with the truststore on the ovirt side, so got that fixed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.