[SOLVED]Error installing the client CentOS 6.7


#1

Hello,

Getting this when installing the client on CentOS 6.7 whit CloudLinux 6.7 + Cpanel 11.52.0 (build 18)

root@asgard [~]# cd letsencrypt
root@asgard [~/letsencrypt]# ./letsencrypt-auto --agree-dev-preview --server \

  https://acme-v01.api.letsencrypt.org/directory auth

Updating letsencrypt and virtual environment dependencies…/root/.local/share/l etsencrypt/lib/python2.6/site-packages/pip/vendor/requests/packages/urllib3/uti l/ssl.py:90: InsecurePlatformWarning: A true SSLContext object is not available . This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs. org/en/latest/security.html#insecureplatformwarning.
InsecurePlatformWarning
./root/.local/share/letsencrypt/lib/python2.6/site-packages/pip/vendor/requests /packages/urllib3/util/ssl.py:90: InsecurePlatformWarning: A true SSLContext ob ject is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https:/ /urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
InsecurePlatformWarning
./root/.local/share/letsencrypt/lib/python2.6/site-packages/pip/vendor/requests /packages/urllib3/util/ssl.py:90: InsecurePlatformWarning: A true SSLContext ob ject is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https:/ /urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
InsecurePlatformWarning
Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-build-_kLIqJ/ConfigArgParse
root@asgard [~/letsencrypt]#


#2

CentOS 6.x runs python 2.6.6 but letsencrypt client requires python 2.7 https://github.com/letsencrypt/letsencrypt/issues/1106

for centos 6, you can install python 2.7 besides python 2.6 via IUS Community yum repo https://ius.io/GettingStarted/ and then install python 2.7

yum -y install python27 python27-devel python27-pip python27-setuptools python27-tools python27-virtualenv --enablerepo=ius

then do what i do and replace python2 with python 2.7 in letsencrypt-auto script

git clone https://github.com/letsencrypt/letsencrypt
cd letsencrypt
sed -i "s|--python python2|--python python2.7|" letsencrypt-auto
./letsencrypt-auto --verbose

[SOLVED] Virtualenv : command not found
#3

Hello @eva2000

Got the IUS Community yum repo installed, how do i install python 2.7? :smile:


#4

Phython 2.6 is on the way of being supported again, see The executable python2 (from --python=python2) does not exist

It’s a known issue: https://github.com/letsencrypt/letsencrypt/issues/1046


#5
yum -y install python27 python27-devel python27-pip python27-setuptools python27-tools python27-virtualenv --enablerepo=ius

#6

I get this now:

Transaction Check Error:
file /usr/bin/2to3 from install of python27-tools-2.7.10-1.ius.el6.x86_64 conflicts with file from package python-tools-2.6.6-64.el6.x86_64


#7

remove python-tools then install

yum -y remove python-tools

#8

Client is now 100% installed :smiley:

Thanks so much for your help @eva2000


Redhat / CentOS 6.x users need python 2.7
#9

Hello,

I tried out the installation via ./letsencrypt-auto, with the intention of only using the client to
acquire a cert, then using Plesk to install the cert. CentOS 6.6, Plesk 11.5.30.

I am having the same problem w/ python version.

Python 2.6 is on the way of being supported again

I am monitoring the issue for updates. https://github.com/letsencrypt/letsencrypt/issues/1046

much thanks


Error while executing instructions mentioned in beta invite [./letsencrypt-auto ]
#10

Transaction Check Error:
file /usr/bin/2to3 from install of python-tools-2.6.6-66.el6_8.x86_64 conflicts with file from package python27-tools-2.7.13-1.ius.centos6.x86_64

[root@NL03 letsencrypt]# yum -y remove python-tools
Loaded plugins: fastestmirror
Setting up Remove Process
No Match for argument: python-tools
Loading mirror speeds from cached hostfile