SOLVED: Certbot cannot verify domain


#1

My domain is: www.jiinxt.com and jiinxt.com

I ran this command:sudo certbot --apache --staging

It produced this output:
Domain: jiinxt.com
Type: connection
Detail: Fetching
http://jiinxt.com/.well-known/acme-challenge/bXIabn-XKwOmPv1JKTuI_F2ma5GvuzghXwCLcz_Swl8:
Timeout

Domain: www.jiinxt.com
Type: connection
Detail: Fetching
http://www.jiinxt.com/.well-known/acme-challenge/SQZeLlUDdmgJxA7IhPLjbl2jFVN9Hj9d0tuB-n2YZMI:
Timeout

My web server is (include version): Apache/2.4.18 (Ubuntu)

The operating system my web server runs on is (include version): ubuntu 16.04

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

If I refresh the page quickly while certbot is verifying, I can view the verifications. Even when I go through a proxy to somewhere in germany I can view the verifications. But certbot keeps failing. Any ideas?


#2

jiinxt.com is advertising an AAAA resource record with an IPv6 address, but when connecting to that IPv6 address, no one is answering: i.e., a time out.

You should either fix your IPv6 connectivity or delete the AAAA record from your hostnames.

By the way, your www subdomain doesn’t have an AAAA-record, so that should have worked… Perhaps you deleted it already? :stuck_out_tongue:


#3

You are the best! that was exactly it!

Thank you!


#4

Yeah. jiinxt.com and www.jiinxt.com had the same AAAA record before.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.