[Solved] Can't renew. Lets encrypt says timeout but no connection attempted

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: practices.immunizationmanagers.org

I ran this command: sudo letsencrypt renew --verbose

It produced this output:

2017-12-07 16:18:46,141:INFO:letsencrypt.cli:Saving debug log to /var/log/letsencrypt/letsencrypt.log
Processing /etc/letsencrypt/renewal/practices.immunizationmanagers.org.conf
2017-12-07 16:18:46,166:INFO:letsencrypt.cli:Cert is due for renewal, auto-renewing…
2017-12-07 16:18:46,200:INFO:requests.packages.urllib3.connectionpool:Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
2017-12-07 16:18:47,060:INFO:letsencrypt.crypto_util:Generating key (2048 bits): /etc/letsencrypt/keys/0059_key-letsencrypt.pem
2017-12-07 16:18:47,064:INFO:letsencrypt.crypto_util:Creating CSR: /etc/letsencrypt/csr/0059_csr-letsencrypt.pem
2017-12-07 16:18:47,067:INFO:requests.packages.urllib3.connectionpool:Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
2017-12-07 16:18:47,229:INFO:requests.packages.urllib3.connectionpool:Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
2017-12-07 16:18:50,116:INFO:letsencrypt.auth_handler:Performing the following challenges:
2017-12-07 16:18:50,117:INFO:letsencrypt.auth_handler:http-01 challenge for practices.immunizationmanagers.org
2017-12-07 16:18:50,122:INFO:letsencrypt.auth_handler:Waiting for verification…
2017-12-07 16:18:50,127:INFO:requests.packages.urllib3.connectionpool:Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
2017-12-07 16:18:53,747:INFO:requests.packages.urllib3.connectionpool:Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
2017-12-07 16:18:56,971:INFO:requests.packages.urllib3.connectionpool:Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
2017-12-07 16:19:00,142:INFO:requests.packages.urllib3.connectionpool:Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
2017-12-07 16:19:03,338:INFO:requests.packages.urllib3.connectionpool:Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
2017-12-07 16:19:03,494:INFO:letsencrypt.reporter:Reporting to user: The following errors were reported by the server:

Domain: practices.immunizationmanagers.org
Type: connection
Detail: Fetching http://practices.immunizationmanagers.org/.well-known/acme-challenge/5suDZma8_m9he2eawWL2g1g7roTAqKpCbNjTSP7KYbk: Timeout

To fix these errors, please make sure that your domain name was entered correctly and the DNS A record(s) for that domain contain(s) the right IP address. Additionally, please check that your computer has a publicly routable IP address and that no firewalls are preventing the server from communicating with the client. If you’re using the webroot plugin, you should also verify that you are serving files from the webroot path you provided.
2017-12-07 16:19:03,494:INFO:letsencrypt.auth_handler:Cleaning up challenges
2017-12-07 16:19:03,496:WARNING:letsencrypt.cli:Attempting to renew cert from /etc/letsencrypt/renewal/practices.immunizationmanagers.org.conf produced an unexpected error: Failed authorization procedure. practices.immunizationmanagers.org (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://practices.immunizationmanagers.org/.well-known/acme-challenge/5suDZma8_m9he2eawWL2g1g7roTAqKpCbNjTSP7KYbk: Timeout. Skipping.

All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/practices.immunizationmanagers.org/fullchain.pem (failure)
1 renew failure(s), 0 parse failure(s)


My web server is (include version): nginx version: nginx/1.10.3 (Ubuntu)

The operating system my web server runs on is (include version):

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.3 LTS
Release: 16.04
Codename: xenial

My hosting provider, if applicable, is: Digital Ocean

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

Hi @majemedia,

The timeout is happening in IPv6, not IPv4. Your site is advertising the address 2604:a880:0:1010::f08:e001 but not accepting inbound connections on this address.

1 Like

@schoen thanks for that. Just removed the IPV6 record from the DNS and it now renewed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.