Social Media Counts Disappeared after installing Let's Encrypt SSL certificate

Hi really love the fact that you exist. The whole process went according to plan but took a little time since it was my first time doing this. I was able to successfully install the certificate from Let’s Encrypt using the instructions provided by GoDaddy and my site is switched over to https. I impressed myself when everything went without a hitch. But I noticed that my social media counts disappeared. The buttons are there but the counts: shares, likes - are gone. Do you have any ideas on how to get them back? It may be due to the WP plugin itself because a social reader thread is also gone. I thought I would let you know in case it’s something you’ve seen before or need to watch for.

My domain is: https://www.coremagazines.com

I ran this command:

It produced this output:

My web server is (include version): cPanel

The operating system my web server runs on is (include version): I think it’s on Apache

My hosting provider, if applicable, is: GD

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): current version of cPanel

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Hi @Cherryl,

Are you referring to how the counts are showing 0, or are some of them missing entirely?

It might be that the addtoany counter script is matching based on the count of the number of times the exact URL has been shared. Since each URL on your site has changed from http:// to https://, perhaps none of the new URLs have been shared at all on social media yet, and the script doesn’t recognize the old http:// URLs (that may well have been shared in the past) as the same.

Hi Schoen, yes I do think that’s the issue http vs. the new https connection. I just tested the AddToAny as by backup but the links below the article are connected to JetPack.

So, the FB feed is missing, the counts are not connected and the links to social are missing too.

Their update happened right after I installed the SSL - and did the redirect. I just checked with my provider and they said everything is in order. I might have to reconnect manually. I’ll consult with JtPk.

Thanks for taking a look at this Schoen.

So, I found the answer to my question so I thought I would share them with you. I’ll have to research further with each social media platform. WARNING for people who don’t want to lose their counts. OMG - how do I get them back?

The share counts have been reset to zero

The totals shown for each official sharing button come from the services themselves: Facebook, Twitter etc. To calculate the total count, those services use the exact URL of the post when it was originally shared.

If your site’s url changes in any way (for example, changing from http to https, or changing the permalink structure), since the exact URL of the posts has now changed, the counts will have been reset to zero.

And since the count data lies with each service and not on WordPress.com or with Jetpack, there’s no way for us to merge or update those totals on our end.

1 Like

I guess you could try to persuade the count service developer to add a special case for HTTPS and HTTP URLs that are otherwise identical, by querying them separately.

1 Like

That sounds good to me. :slight_smile: