SO Frustrated - SiteGround SSL Error

My domain is:

I ran this command: Siteground > SSL > Let’s Encrypt on the above domain

It produced this output:
This error Failed to install Let’s Encrypt for .

ERROR: acmebot->create_new_order: Net::ACME2::x::ACME: “” indicated an ACME error: 429 Too Many Requests (429 urn:ietf:params:acme:error:rateLimited (The request exceeds a rate limit) (Error creating new order :: too many certificates already issued for exact set of domains:, see ==> Net::ACME2::x::Generic::new(‘Net::ACME2::x::ACME’, ‘“” indicated an ACME error: 429 Too Many Requests (429 urn:ietf:params:acme:error:rateLimited (The request exceeds a rate limit) (Error creating new order :: too many certificates already issued for exact set of domains:, see’, HASH(0x3941128)) (called in /usr/local/lib64/perl5/Net/ACME2/X/ at line 31) ==> Net::ACME2::x::ACME::new(‘Net::ACME2::x::ACME’, HASH(0x3941128)) (called in /usr/local/lib64/perl5/X/ at line 169) ==> X::Tiny::create(‘Net::ACME2::X’, ‘ACME’, HASH(0x3941128)) (called in /usr/local/lib64/perl5/Net/ACME2/ at line 159) ==> Net::ACME2::HTTP::_request(Net::ACME2::HTTP=HASH(0x38b9230), ‘POST’, ‘’, HASH(0x3963d98), HASH(0x3938848)) (called in /usr/local/lib64/perl5/Net/ACME2/ at line 181) ==> Net::ACME2::HTTP::_request_and_set_last_nonce(Net::ACME2::HTTP=HASH(0x38b9230), ‘POST’, ‘’, HASH(0x3963d98), HASH(0x3938848)) (called in /usr/local/lib64/perl5/Net/ACME2/ at line 108) ==> Net::ACME2::HTTP::_post(Net::ACME2::HTTP=HASH(0x38b9230), ‘create_key_id_jws’, ‘’, HASH(0x37c04f8)) (called in /usr/local/lib64/perl5/Net/ACME2/ at line 88) ==> Net::ACME2::HTTP::post_key_id(Net::ACME2::HTTP=HASH(0x38b9230), ‘’, HASH(0x37c04f8)) (called in /usr/local/lib64/perl5/Net/ at line 555) ==> Net::ACME2::_post_url(Net::ACME2::LetsEncrypt=HASH(0x37d4d30), ‘’, HASH(0x37c04f8), undef) (called in /usr/local/lib64/perl5/Net/ at line 537) ==> Net::ACME2::_post(Net::ACME2::LetsEncrypt=HASH(0x37d4d30), ‘newOrder’, HASH(0x37c04f8)) (called in /usr/local/lib64/perl5/Net/ at line 315) ==> Net::ACME2::create_order(Net::ACME2::LetsEncrypt=HASH(0x37d4d30), ‘identifiers’, ARRAY(0x38db0c0)) (called in /usr/local/lib64/perl5/ at line 94) ==> (eval)(Net::ACME2::LetsEncrypt=HASH(0x37d4d30), ‘identifiers’, ARRAY(0x38db0c0)) (called in /usr/local/lib64/perl5/ at line 93) ==> Acmebot::create_order(Net::ACME2::LetsEncrypt=HASH(0x37d4d30), ‘/etc/letsencrypt/authzs/1586925100.authzs’, ‘’, ‘’) (called in /usr/local/lib64/perl5/ at line 182) ==> Acmebot::order_certs(Net::ACME2::LetsEncrypt=HASH(0x37d4d30), ‘/etc/letsencrypt/authzs/1586925100.authzs’, ‘DNS’, HASH(0x3825ce8), ‘’, ‘’) (called in /usr/local/lib64/perl5/ at line 237) ==> Acmebot::issue_cert(HASH(0x38d6f00), HASH(0x38d6c30)) (called in lib/Avalon/ at line 473) ==> (eval)(HASH(0x38d6f00), HASH(0x38d6c30)) (called in lib/Avalon/ at line 473) ==> Avalon::Ssl::issue_le(DBI::db=HASH(0x38f5298), HASH(0x2e423f8), HASH(0x38d36a0)) (called in lib/Avalon/ at line 536) ==> Avalon::Ssl::create_le(HASH(0x3051288), HASH(0x38d36a0)) (called in /home/avalon/avalon/workers/…/lib/Avalon/Utils/ at line 186) ==> (eval)(HASH(0x3051288), HASH(0x38d36a0)) (called in /home/avalon/avalon/workers/…/lib/Avalon/Utils/ at line 185) ==> Avalon::Utils::jobs::task_execute(HASH(0x3051288)) (called in /home/avalon/avalon/workers/ at line 86) ==> main::do_task(HASH(0x3051288)) (called in /home/avalon/avalon/workers/ at line 108) ==> main::api_task_router(Gearman::Job=HASH(0x2dac838)) (called in /usr/local/lib64/perl5/Gearman/ at line 344) ==> (eval)(Gearman::Job=HASH(0x2dac838)) (called in /usr/local/lib64/perl5/Gearman/ at line 344) ==> Gearman::Worker::work(Gearman::Worker=HASH(0x2d7c618)) (called in /home/avalon/avalon/workers/ at line 190) ==> main::main(‘main’) (called in /home/avalon/avalon/workers/ at line 41)

My web server is (include version): Wordpress 5.4

My hosting provider, if applicable, is: Siteground

I can login to a root shell on my machine (yes or no, or I don’t know): no

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): yes

Additional Notes:

So frustrated. I’ve been on support now 4 times and no one can help me. We pointed the domain over to Siteground on Friday. We applied Friday afternoon, it gave that error. I contacted support, they told me to wait 12 hours & try again. So I did that. Still an error. Contacted support, they told me wait another 12 hours. Here we are now on Tuesday evening with the SAME error still showing even though I waited a full 24 hours to check. Support says there’s nothing I can do but wait even more, but I’m starting to think it’s more than that…We have to get this site up & rolling stat. It was supposed to go live over the weekend :frowning:

Any other solutions?!

The link in the error message has more information.

Looking at the Certificate Transparency logs, your certificates were issued 2020-04-10 19:14 - 19:38 UTC, so you can next issue another duplicate certificate at about 2020-04-17 19:14:45.

I don’t get it, SiteGround is wasting your time and their own time, and Let’s Encrypt’s resources, by making something up about trying again every 12 hours instead of just telling you the truth. :neutral_face:

Do you know what happened to those 5 certificates? Do you have them? Does SiteGround have them? Can one of them be used?

You can bypass the duplicate certificate rate limit by issuing a certificate that isn’t a duplicate: either add another (sub)domain, or create two certificates, one for each name. But you might need SiteGround’s assistance to do something like that with their services.

If the client you’re using keeps issuing and deleting certificates, you need to fix that before doing the same thing all over again, though.


Thank you so much for your response!

Yeah it’s so frustrating. In the account no SSL certificates show up, and I had asked Siteground if they could do anything from their end & they couldn’t so I’m really confused with all this.

The reason why you were unable to install the SSL certificate is that there were too many failed installation attempts, so the system added a temporary block. Once the domain propagated and the limit expired, the SSL was successfully installed for your domain.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.